Bug 1277360 - doc: update specifying the packages in commands
doc: update specifying the packages in commands
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 02:01 EST by Igor Gnatenko
Modified: 2016-02-16 23:23 EST (History)
6 users (show)

See Also:
Fixed In Version: dnf-1.1.6-1.fc23 dnf-1.1.6-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 23:23:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2015-11-03 02:01:25 EST
$ sudo dnf info python2-pandas
Last metadata expiration check performed 0:29:46 ago on Tue Nov  3 06:48:16 2015.
Error: No matching Packages to list
$ sudo dnf install python2-pandas
Last metadata expiration check performed 0:29:50 ago on Tue Nov  3 06:48:16 2015.
Dependencies resolved.
================================================================================
 Package                 Arch         Version               Repository     Size
================================================================================
Installing:
 blosc                   x86_64       1.6.1-2.fc23          rawhide        39 k
 python-Bottleneck       x86_64       0.6.0-5.fc23          rawhide       1.0 M
 python-numexpr          x86_64       2.3-6.fc23            rawhide       170 k
 python-pandas           x86_64       0.17.0-2.fc24         rawhide       6.5 M
 python-tables           x86_64       3.2.0-3.fc23          rawhide       1.2 M

Transaction Summary
================================================================================
Install  5 Packages

Total download size: 8.9 M
Installed size: 51 M
Is this ok [y/N]: n
Operation aborted.
$ sudo dnf provides python2-pandas
Last metadata expiration check performed 1:10:17 ago on Tue Nov  3 06:48:16 2015.
python-pandas-0.17.0-2.fc24.x86_64 : Python library providing high-performance
                                   : data analysis tools
Repo        : rawhide

python-pandas-0.17.0-2.fc24.x86_64 : Python library providing high-performance
                                   : data analysis tools
Repo        : koji


'info' should use something like dnf.subject.Subject() to try to guess if it's provided by someone I think.
P.S. I've not looked into the code.


Versions:
$ rpm -q libsolv hawkey dnf librepo
libsolv-0.6.14-2.fc24.x86_64
hawkey-0.6.2-1.fc24.x86_64
dnf-1.1.3-1.fc24.noarch
librepo-1.7.17-1.fc24.x86_64
Comment 1 Jaroslav Mracek 2015-11-09 07:30:11 EST
This behavior is not a bug. See documentation https://dnf.readthedocs.org/en/latest/command_ref.html#info-command-label where you should use package-spec (see description - http://dnf.readthedocs.org/en/latest/command_ref.html#specifying-packages-label).
Comment 2 Igor Gnatenko 2015-11-09 07:44:23 EST
Then install also should not install this package.
Comment 3 Honza Silhan 2015-11-18 07:13:30 EST
Now I've got your point. In install command is not mentioned <package-provide>. All command should be updated and mention the file of the package searches and the order of parsing the <spec>.
Comment 4 Jaroslav Mracek 2016-01-05 04:50:03 EST
The new pull-request was made https://github.com/rpm-software-management/dnf/pull/391 to cover this problematic.
Comment 5 Fedora Update System 2016-01-26 05:34:56 EST
dnf-plugins-core-0.1.16-1.fc23 dnf-1.1.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4
Comment 6 Fedora Update System 2016-01-26 05:36:02 EST
dnf-plugins-core-0.1.16-1.fc22 dnf-1.1.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37
Comment 7 Fedora Update System 2016-01-26 14:52:58 EST
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4
Comment 8 Fedora Update System 2016-01-28 13:20:22 EST
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-01-28 18:19:38 EST
dnf-1.1.6-1.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37
Comment 10 Fedora Update System 2016-02-03 08:07:14 EST
dnf-1.1.6-2.fc22 dnf-plugins-core-0.1.16-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37
Comment 11 Fedora Update System 2016-02-03 18:27:09 EST
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37
Comment 12 Fedora Update System 2016-02-16 23:22:28 EST
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.