Bug 1277364 - http endpoint returned instead of https when cinder service calls are made
http endpoint returned instead of https when cinder service calls are made
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
All Linux
unspecified Severity medium
: ---
: 6.0 (Juno)
Assigned To: Gorka Eguileor
Prasanth Anbalagan
: ZStream
Depends On: 1237207
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 02:23 EST by Sergey Gotliv
Modified: 2018-02-08 06:01 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.2.3-11.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the versions resource in the Block Storage service API would incorrectly report the endpoint address if the address was behind a proxy or SSL terminator. With this update, a "public_endpoint" configuration option has been added that correctly points to the pubic URL for the versions resource.
Story Points: ---
Clone Of: 1237207
Environment:
Last Closed: 2016-01-21 08:54:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 errata-xmlrpc 2016-01-21 08:54:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0059.html

Note You need to log in before you can comment on or make changes to this bug.