Bug 1277403 - SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-machined.
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 1276931
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e613ab6e01d19e0ce96bcbc4bfa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 04:22 EST by Philipp Ebbecke
Modified: 2015-11-09 01:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 01:40:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Ebbecke 2015-11-03 04:22:19 EST
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-machined.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed getattr access on the systemd-machined file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:init_exec_t:s0
Target Objects                /usr/lib/systemd/systemd-machined [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-219-25.fc22.x86_64
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-03 10:17:44 CET
Last Seen                     2015-11-03 10:17:44 CET
Local ID                      7b8bc9fe-6d60-4c50-92f7-c35e7062c760

Raw Audit Messages
type=AVC msg=audit(1446542264.618:1202): avc:  denied  { getattr } for  pid=24971 comm="abrt-hook-ccpp" path="/usr/lib/systemd/systemd-machined" dev="dm-2" ino=2239521 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:init_exec_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,init_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-09 01:40:38 EST

*** This bug has been marked as a duplicate of bug 1276931 ***

Note You need to log in before you can comment on or make changes to this bug.