Bug 127743 - fresh install onto reiserfs freezes after formatting filesystem (kernel bug suspected)
fresh install onto reiserfs freezes after formatting filesystem (kernel bug s...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://bugme.osdl.org/show_bug.cgi?id...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 05:13 EDT by Barry K. Nathan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 11:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog at the final screen before installation starts (30.55 KB, text/plain)
2004-07-13 05:15 EDT, Barry K. Nathan
no flags Details
syslog after the installer freezes (31.19 KB, text/plain)
2004-07-13 05:18 EDT, Barry K. Nathan
no flags Details
anaconda.log at the final screen before installation starts (8.73 KB, text/plain)
2004-07-13 05:19 EDT, Barry K. Nathan
no flags Details
anaconda.log after the installer freezes (8.95 KB, text/plain)
2004-07-13 05:21 EDT, Barry K. Nathan
no flags Details

  None (edit)
Description Barry K. Nathan 2004-07-13 05:13:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
When doing an install onto a new reiserfs / partition (and not
installing onto any other partitions), the installer freezes up after
successfully formatting the new reiserfs filesystem. "ps" on the
command line (on virtual terminal 2) shows that one "anaconda" process
is stuck in D state, and it's possible to accidentally freeze up the
bash shell on VT 2 as well. (Now that I'm writing this up, I think I
should see what mount is freezing things up, but I'll do that and add
it as a comment after the initial bug report.)

Due to the way it's freezing up, I suspect the kernel is involved somehow.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.478, anaconda-10.0.1-2

How reproducible:
Always

Steps to Reproduce:
(some steps have been omitted for brevity, but the important stuff is
here)
1. Boot the installer with "linux reiserfs" or some variant thereof.
2. Choose any kind of install (personal workstation, custom, etc.)
3. Format a / partition as reiserfs, and do not format or mount any
other partitions.
4. Go with whatever type of package selection you want.
5. Click "Next" on the last screen and let the install begin.
    

Actual Results:  The root filesystem is formatted and (I think)
mounted, then the installer just freezes up.

Expected Results:  Installation should proceed without problems.

Additional info:

On my test system I am now reinstalling FC2 on a reiserfs partition. I
will then attempt an upgrade to FC-devel (from 20040712); that will
let me see whether this bug only occurs on fresh installs.

I can reproduce this bug 100% of the time on both of the test systems
on which I have tried fc-devel reiserfs installs.

I will be attaching a few different log files which may provide some
hints.
Comment 1 Barry K. Nathan 2004-07-13 05:15:49 EDT
Created attachment 101852 [details]
syslog at the final screen before installation starts
Comment 2 Arjan van de Ven 2004-07-13 05:16:16 EDT
why not use ext3 ? 
Comment 3 Barry K. Nathan 2004-07-13 05:18:45 EDT
Created attachment 101853 [details]
syslog after the installer freezes

This is the last line from the log before the freeze, and it's one I've never
seen before from the kernel:

<4>inode_doinit_with_dentry:  getxattr returned 1 for dev=hdc10 ino=3

BTW, this is with SELinux "Disabled" in the SELinux menu in the installer GUI.
The same freeze also happens with SELinux set to "Enabled" or whatever the 3rd
choice in the menu is (the choice that activates enforcing mode).
Comment 4 Barry K. Nathan 2004-07-13 05:19:45 EDT
Created attachment 101854 [details]
anaconda.log at the final screen before installation starts
Comment 5 Barry K. Nathan 2004-07-13 05:21:26 EDT
Created attachment 101855 [details]
anaconda.log after the installer freezes
Comment 6 Barry K. Nathan 2004-07-13 05:22:28 EDT
At least for some of my workloads, reiserfs feels considerably faster.
(I haven't timed it however.)
Comment 7 Arjan van de Ven 2004-07-13 05:25:48 EDT
At the same level of dataprotection, reiserfs doesn't seem to be
faster than the 2.6 ext3. It does seem to however create longer
latencies ;(
Comment 8 Barry K. Nathan 2004-07-13 05:53:55 EDT
Hmmm, I'll retest the two filesystems with newer 2.6 kernels, paying
more attention to the "same level of dataprotection" aspect. (With
2.4, I did time some of my workloads, and reiserfs was typically twice
as fast as ext3. Of course, 2.6 changes things enough that I can't
rely on those numbers anymore and I need to repeat the tests.)

Anyway, reiserfs has other advantages -- for instance, when tails are
enabled, it uses much less space if you're storing tons of tiny files.
Comment 9 Barry K. Nathan 2004-07-13 06:05:01 EDT
Let me clarify my last comment:

My reiserfs vs. ext3 tests under 2.4 did not involve writing any data
and were conducted with atimes disabled, so I doubt the journalling
modes of the two filesystems would have made a significant difference.
(BTW, I also tested JFS at the time, and ext3 was 4.5X as fast as JFS.)

Also, I'm *not* trying to get Red Hat to change the default
filesystem. ext3 is a good default, and I do use it on most of my
systems. Nonetheless, it would be nice if reiserfs worked as an option.
Comment 10 Barry K. Nathan 2004-07-13 08:55:42 EDT
I've finished testing an anaconda upgrade from FC2-on-reiserfs to
FC-devel: anaconda gets stuck in D state at "Finding packages to
upgrade..." -- there's some disk activity for maybe a few minutes, and
then it freezes up (although the hourglass cursor keeps tumbling).

AFAICT, once the freeze happens, anything else that tries to access
/mnt/sysimage (e.g. "ls /mnt/sysimage" on VT 2) gets stuck in D state.
Comment 11 Warren Togami 2004-07-13 09:04:27 EDT
Comment #3 is not a surprise, because reiserfs from upstream 2.6 does
not support xattrs.  I do not know however if that is related to the
behavior you are seeing, or if this is fixable with only Anaconda changes.

Realistically Red Hat probably will not expend any resources into
looking into this issue for FC3 because reiserfs is not a supported
feature.  However if the problem is diagnosed and a good fix is
submitted by the community, and it is limited to Anaconda, we will try
to review and include it.  If it requires kernel changes, then pretty
much the only way it will get into FC3 is if you get it into the
upstream kernel.
Comment 12 Barry K. Nathan 2004-07-13 09:39:47 EDT
Somehow I thought xattr support had been added to reiserfs upstream at
some point recently. Perhaps I'm just confusing it with something
else, though... Er, wait, what's this?

CONFIG_REISERFS_FS_XATTR=y

(this is from the .config for kernel-2.6.7-1.478 i686)
Comment 13 Warren Togami 2004-07-13 09:50:44 EDT
Wow, that's surprising.  I recall somebody saying 'maybe 2.7' for that
feature.  Maybe they changed their mind later.  In any case I think
FC2's original kernel lacked that capability.
Comment 14 Barry K. Nathan 2004-07-13 10:05:59 EDT
Yes, it was definitely missing from the original FC2 kernel. IIRC
there was some kind of argument on lkml about this; Hans Reiser wanted
to wait (for reiserfs v4, if I'm not mistaken) but he was overriden by
other people.


BTW, JFS is also failing, but in a different manner. (Maybe this
belongs in a bug of its own, but I want to look at this a bit more
first.) Instead of freezing up, it gets far enough to fail with this:

---begin quote---
Error Installing Package

There was an error installing fedora-logos-1.1.25-1.2.  This can
indicate media failure, lack of disk space, and/or hardware problems.
 This is a fatal error and your install will be aborted.  Please
verify your media and try your install again.

Press the OK button to reboot your system.
---end quote---

(I also tried XFS. To make a long story short, my testing was
inconclusive because of mistakes I made, and I'll repeat it correctly
later, but XFS is completely unaffected by anything remotely
resembling this bug, and it's probably in the same shape as it was in
FC2.)
Comment 15 Barry K. Nathan 2004-07-13 11:06:12 EDT
I'm lowering the severity now that I have a workaround: Add
"selinux=0" to the installer command line as well as "reiserfs" and/or
"jfs". "selinux=0" prevents the problems with both jfs and reiserfs.

I can think of possible changes to anaconda to keep jfs and reiserfs
installs from failing without "selinux=0", but I think it would also
be an additional, unnecessary maintenance burden on Red Hat down the road.

There's a patch that makes the JFS xattrs SELinux-compatible, but it
hasn't been committed upstream for some reason. Anyway, I'm not going
to say anything else about JFS in this bug, to prevent this bug from
becoming hydra-headed.

My best guess about the reiserfs freeze issue is that it's something
I'll have to handle w/the upstream maintainers. So, I'll close this
bug as UPSTREAM for now, and if it turns out to be specific to the FC
kernel, I'll consider reopening the bug.
Comment 16 Barry K. Nathan 2004-07-16 02:24:05 EDT
I've now reported this to upstream as bugme.osdl.org #3080:
http://bugme.osdl.org/show_bug.cgi?id=3080

Note You need to log in before you can comment on or make changes to this bug.