Bug 127746 - xinput.sh is missing the support of lang.sh
xinput.sh is missing the support of lang.sh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: EasyFix, i18n
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-13 07:43 EDT by Akira TAGOH
Modified: 2013-01-14 09:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 04:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix problem and also add xinput.d/default support (3.00 KB, patch)
2004-07-13 09:34 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2004-07-13 07:43:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.1)
Gecko/20040711

Description of problem:
due to calling lang.sh stuff was removed, even if LC_CTYPE is set in
$HOME/.i18n, xinput.sh doesn't run proper input method. this change
disallows people who lives in en_US locale say and who want to use the IM.


Version-Release number of selected component (if applicable):
xinitrc-4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1.set LANG=en_US.UTF-8 in /etc/sysconfig/i18n
2.set LC_CTYPE=ja_JP.UTF-8 in $HOME/.i18n
3.make sure iiimf-x or kinput2 installed
    

Actual Results:  no input method is running

Expected Results:  kinput2 or httx is running

Additional info:

just adding the below in the top of xinput.sh will gets working again.

if [ -r /etc/profile.d/lang.sh ]; then
  . /etc/profile.d/lang.sh
fi
Comment 1 Jens Petersen 2004-07-13 09:34:32 EDT
Created attachment 101859 [details]
patch to fix problem and also add xinput.d/default support

My bad.  Ok, this patch against 4.0.1-1 should fix the problem.

It also adds a small feature: allowing xinput.d/ dirs to have
a fallback all locale default file.
Comment 7 Mike A. Harris 2004-08-21 09:46:46 EDT
Patch applied to 4.0.2-1 in rawhide.  Test and confirm it works
properly as soon as possible, so any problems can be fixed in
time.
Comment 9 Lawrence Lim 2004-09-13 04:03:00 EDT
Confirmed fixed. Tested with xinitrc-4.0.3-1.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.