Bug 1277479 - crush: straw2: divide by 0 when weight is 0
crush: straw2: divide by 0 when weight is 0
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity high
: rc
: 1.3.2
Assigned To: Josh Durgin
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 07:40 EST by Benjamin Schmaus
Modified: 2017-07-30 11:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 12:58:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 11357 None None None Never

  None (edit)
Description Benjamin Schmaus 2015-11-03 07:40:56 EST
Description of problem:

Client is seeing the following issue with nova instances:

crush: straw2: divide by 0 when weight is 0

Client uses Ubuntu for OpenStack and RHEL7 with Ceph 1.3.

Believed to be the following upstream bug:

http://tracker.ceph.com/issues/11357


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Instance should launch

Expected results:
Instance fails w/ error:  on MON Nov  3 00:26:01 ndc-003-022 kernel: [1566825.894236] libceph: mon1 172.16.151.16:6789 feature set mismatch, my 2b84a042a42 < server's 102b84a042a42, missing 100000000

Additional info:

Upstream bug appears to be committed in code:

git tag --contains b5921d55
v0.94.1
v0.94.1.2
v0.94.1.3
v0.94.1.4
v0.94.1.5
v0.94.1.6
v0.94.1.7
v0.94.2
v0.94.3
Comment 4 Benjamin Schmaus 2015-11-03 10:58 EST
Created attachment 1089102 [details]
tcpdump from OSP client to Mon
Comment 5 Ken Dreyer (Red Hat) 2015-11-03 11:07:29 EST
Jason confirmed this is a RADOS issue, not RBD-specific - adjusting sub-component to match.
Comment 6 Benjamin Schmaus 2015-11-03 12:57:46 EST
This is not a bug - client upgraded from firefly to hammer but never restarted instances hence not picking up new hammer libraries for qemu process.

Closing.....

Note You need to log in before you can comment on or make changes to this bug.