Bug 127748 - generate-modprobe.conf cannot find old version of modprobe Giving up.
generate-modprobe.conf cannot find old version of modprobe Giving up.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 08:19 EDT by Pierre Francois
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 14:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Francois 2004-07-13 08:19:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Running /sbin/generate-modprobe.conf after updating from FC1 to FC2
doesn't work: next message is issued:

Cannot find old version of modprobe. Giving up.

It seems absurd dat /sbin/generate-modprobe.conf asks the old version
of modprobe since this script is intented for configuring a file under
newest kernel.



Version-Release number of selected component (if applicable):
2.4.26-16

How reproducible:
Didn't try

Steps to Reproduce:
1. Install FC1
2. modify /etc/modules.conf for adding some modules (for the Smart
Link modem v.gr.)
3. Upgrade to FC2 with Anaconda
    

Actual Results:  A lot of modules are missing in etc/modprobe.conf 

Expected Results:  The modules present in /etc/modules.conf (kernel
2.4 under FC1) should be transferred to /etc/modprobe.conf (kernel 2.6
under FC2) in the way sbin/generate-modprobe.conf do (when it's working).

Additional info:

I'm not sure anaconda is using the script
/sbin/generate-modprobe.conf, but when the system is upgraded from FC1
to FC2, it whould be useful to sbin/generate-modprobe.conf to work
Comment 1 Bill Nottingham 2005-01-25 14:28:00 EST
Did you have a modprobe.conf before upgrading? If so, entries will not
be converted.
Comment 2 Pierre Francois 2005-01-25 14:38:06 EST
I think the mistake I did was to upgrade from FC1 to FC2 with the CD
of FC1, instead of using a new version af Anaconda.

Note You need to log in before you can comment on or make changes to this bug.