This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1277492 - make run_suite script work with latest stable basic ovirt tests
make run_suite script work with latest stable basic ovirt tests
Status: CLOSED CURRENTRELEASE
Product: ovirt-system-tests
Classification: Community
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
unspecified Severity unspecified
: milestone2
: 0.4
Assigned To: David Caro
Pavel Stehlik
ci
:
Depends On:
Blocks: 1279411
  Show dependency treegraph
 
Reported: 2015-11-03 08:13 EST by Yaniv Bronhaim
Modified: 2016-04-24 07:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-24 07:29:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48163 master MERGED system_tests: Adapting to the new lago tests repo Never

  None (edit)
Description Yaniv Bronhaim 2015-11-03 08:13:58 EST
Project ovirt-testing-framework-tests is aimed to include different type of testing suites. This script should simplify the run of those script and be used by variate jenkins jobs for different purposes, such as for vdsm functional tests.

Therefore, in this RFE we need to merge between the tests in lago core code to the once in ovirt-testing-framework-tests/basic_suite and have it part of the current 3.5 job (http://jenkins.ovirt.org/job/ovirt_3.5_system-tests-el7-x86_64/) means that instead of running it with lago commands or additional script, the job will only run with the command - "./run_suite basic_suite"
Comment 1 Eyal Edri 2015-11-05 10:21:31 EST
is this solved for lago 0.3? doesn't this means the opposite of splitting the tests ?
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-05 10:21:35 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 David Caro 2015-11-05 11:14:58 EST
It's not solved, what yaniv means is that in the repo where we will have the tests after the split, there's a shell script that handles the test execution, and that we should use that instead of hardcoding the test execution in the jenkins job (as it does now).

I agree to certain point, still have to find a better way to integrate with the standard ci, but yes, essentially we will replace the jenkins-hardcoded script by one simple ./run_suite <mysuite> line.

That also eases the manual execution.

We should decide how to distribute that among devs and how to ease the usage, but that's a future task.
Comment 4 Eyal Edri 2015-11-11 03:12:29 EST
david, is the patch relevant for the bug, if so - please move to POST (shouldn't the hook do it btw?)
Comment 5 David Caro 2015-11-11 04:30:38 EST
I added the hook that moves to POST a couple days ago, but forgot to move the bugs that had the patch added before that

Note You need to log in before you can comment on or make changes to this bug.