Bug 1277495 - remove the pre-3.6 setupnetworks api
remove the pre-3.6 setupnetworks api
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Martin Mucha
Michael Burman
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 08:19 EST by Martin Mucha
Modified: 2016-07-05 04:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:03:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
pstehlik: testing_plan_complete-
rule-engine: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54076 master ABANDONED restapi: remove 3.0 API (attach,detach,update,bond manipulations) and 3.2 SetupNetworksCommand 2016-03-23 07:31 EDT
oVirt gerrit 54367 master MERGED Remove setupNetworks command 2016-03-08 13:06 EST
oVirt gerrit 54409 master ABANDONED core: setupNetworkSupported—>hostSetupNetworkSupported 2016-03-16 10:02 EDT
oVirt gerrit 54410 master ABANDONED restapi: Remove SetupNetworksCommand 2016-03-10 09:03 EST
oVirt gerrit 54411 master MERGED core: remove SetupNetworksCommand and friends. 2016-03-23 08:19 EDT
oVirt gerrit 54412 master MERGED core: remove legacy support from HostNetworkAttachmentsPersister 2016-03-23 08:24 EDT

  None (edit)
Description Martin Mucha 2015-11-03 08:19:11 EST
Description of problem:
Currently we support three ways to do certain tasks, for example detaching network, breaking bond etc. The oldest one is quite buggy and it's not worthy to have it in code base if it's not even maintained any more.
Comment 1 Martin Mucha 2015-11-03 08:36:55 EST
*** Bug 1277496 has been marked as a duplicate of this bug. ***
Comment 2 Dan Kenigsberg 2015-11-05 09:26:36 EST
Juan, would you guide us how to mark an existing API as deprecated?
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-05 09:26:40 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Juan Hernández 2015-11-05 09:40:09 EST
The old "setupnetworks" action is already marked as deprecated in 3.6:

  https://github.com/oVirt/ovirt-engine/commit/d269e5f0552f99c9b70b95456a9f481be8c795e9#diff-3205c1e6ccdb0cbdefc9e4392d9feb9cR2094

The next logical step is to remove it completely for the master branch. To do so remove it and update this file:

  https://github.com/oVirt/ovirt-engine/blob/master/backend/manager/modules/restapi/README.md

If possible include there instructions on how to to migrate from the old action to the new one. The more detailed the better.
Comment 5 Sandro Bonazzola 2016-07-05 04:03:42 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.