Bug 1277508 - a C TUI?
a C TUI?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 08:41 EST by Richard Jasmin
Modified: 2015-11-03 16:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 16:47:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-11-03 08:41:19 EST
Description of problem:
This seems odd. From the days of yore, compilers have had a TUI. But on Linux, someone seems to be missing the boat. I dunno if yall are old school hacking in vi or what but C doesnt seem to have a TUI.
Free Pascal has one.
DOS has a few.

And before you get me going, there are a few available.
RHIDE comes to mind.
The code has been freed and is no longer borland specific, so thats not the reason why.

Most modern OSes should be based off the basic core functions anyhoo(TVision concept) and TVision has a C counterpart, if not mistaken it was ported into Pascal from C.
So thats not the reason either.

I know people are all over GUI environments and GUI tools but I think this lack of TUI is embarrassing for yall C folk.

No, unlike FreePascal, cpp by itself does NOT load a UI interface. It actually hangs the compiler. 'CP' referes to the internal linux copy command. Whereas with FreePascal, fp invokes the TUI and fpc is the actual compiler by itself. Maybe you want to follow that convention?

Version-Release number of selected component (if applicable):
22

How reproducible:
Well?

Steps to Reproduce:
??

Actual results:
wha?

Expected results:
I dunno what yall want to call this but Id say its in high order to make a TUI.
Comment 1 Kevin Fenzi 2015-11-03 16:47:12 EST
If you are looking for a text based IDE (Integrated Development Env), you could use something like vim or emacs. I'm sure there are other ones out there, but this isn't the place for this. 

When asking general support questions, please use one of the support channels for that: 

fedora users list: https://lists.fedoraproject.org/mailman/listinfo/users
or https://ask.fedoraproject.org

Folks there can help you find software you are looking for or answer general support questions. 

Good luck.

Note You need to log in before you can comment on or make changes to this bug.