Bug 127751 - raid1 mirrors always delay resync when drives readded
raid1 mirrors always delay resync when drives readded
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 09:14 EDT by Hrunting Johnson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.7-1.494.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 16:40:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hrunting Johnson 2004-07-13 09:14:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
If you have a raid1 mirror that fails, you can remove the drive and
replace it, but when you go to add that drive back, it always goes in
with a delayed resync (it will wait until the next reboot). 
Furthermore, if you have other arrays that also use that drive and you
try to sync them (raid1 or otherwise), they too will be delayed
because of the raid1 array and if you reboot the system, you can then
get fs corruption because that delayed status isn't properly handled.

This is fixed in 2.6.8-rc1 by two patches from Neil Brown:
  o Fix raid1 read_balancing code
  o md: Fix up handling for read error in raid1

If these could make their way into an errata release sooner rather
than later, it would save a lot of grief working with RAID arrays.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435.2.3

How reproducible:
Always

Steps to Reproduce:
1. setup raid1
2. hard-fail out a drive
3. try to readd drive
    

Actual Results:  Drive goes in with a delayed resync

Expected Results:  Drive beings resyncing immediately

Additional info:
Comment 1 Hrunting Johnson 2004-09-17 16:40:38 EDT
This was fixed in subsequent erratas which contained patches from Neil
Brown.

Note You need to log in before you can comment on or make changes to this bug.