Bug 1277515 - Registries - auto_complete_search returning 404 every time user activates search field
Registries - auto_complete_search returning 404 every time user activates sea...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 08:52 EST by Roman Plevka
Modified: 2017-08-01 16:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:33:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12503 None None None 2016-04-22 12:27 EDT

  None (edit)
Description Roman Plevka 2015-11-03 08:52:08 EST
Description of problem:
There is 404 error in the console every time user clicks into Registries search field.
or no entity matching the query is found.

It is caused by calling 
'https://<FQDN>/registries/auto_complete_search?search='
immediately after the search field is being clicked (sending an empty query)


Version-Release number of selected component (if applicable):
katello-2.2.0.16-1.el7sat.noarch
katello-certs-tools-2.2.1-1.el7sat.noarch
katello-common-2.2.0.16-1.el7sat.noarch
katello-debug-2.2.0.16-1.el7sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-2.3.20-1.el7sat.noarch
katello-installer-base-2.3.20-1.el7sat.noarch
katello-server-ca-1.0-1.noarch
katello-service-2.2.0.16-1.el7sat.noarch

How reproducible:
every time

Steps to Reproduce:
1. Navigate to Containers -> Registries
2. click into search bar
3. BONUS - type any query that yelds 0 results
4. spot 404 in browser console

Actual results:
query sent with parameter "search="
404 in the console

Expected results:
- the query shouldn't be sent with no parameters
- the server-side script should handle the request properly (no 404)

Additional info:
Comment 2 Brad Buckingham 2015-11-16 16:20:39 EST
Created redmine issue http://projects.theforeman.org/issues/12503 from this bug
Comment 3 Bryan Kearney 2015-11-16 18:06:09 EST
Upstream bug component is Provisioning
Comment 4 Bryan Kearney 2015-11-17 04:05:15 EST
Upstream bug component is Content Management
Comment 5 Bryan Kearney 2016-02-05 14:09:36 EST
Upstream bug component is Content Management
Comment 6 Bryan Kearney 2016-07-08 16:48:24 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 8 Bryan Kearney 2016-11-08 14:19:44 EST
Has this been resolved with the Docker V2 updates?
Comment 9 Bryan Kearney 2017-03-06 17:44:29 EST
Roman, can you retest? Upstream thinks this is fixed.
Comment 10 Roman Plevka 2017-03-07 06:05:01 EST
(In reply to Bryan Kearney from comment #9)
> Roman, can you retest? Upstream thinks this is fixed.

The issue is still present in 6.2.8
Comment 11 Bryan Kearney 2017-08-01 16:33:25 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.