Bug 1277593 - RFE: ironic should take care of setting PXE boot enabled by default on physical nodes [NEEDINFO]
RFE: ironic should take care of setting PXE boot enabled by default on physic...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity low
: ga
: 9.0 (Mitaka)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: FutureFeature, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 10:45 EST by Nicolas Auvray
Modified: 2016-10-04 00:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-13 08:42:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lmartins: needinfo? (nauvray)
lmartins: needinfo? (nauvray)


Attachments (Terms of Use)

  None (edit)
Description Nicolas Auvray 2015-11-03 10:45:39 EST
Description of problem:

This is feedback from customer. When deploying a large amount of machines, it could be a real pain to make sure that every node has PXE boot configured by default. Maybe ironic should take care of this through pxe_idrac and pxe_ipmitool driver automatically, rather than setting it up on all nodes manually.


Version-Release number of selected component (if applicable):

python-ironicclient-0.5.1-11.el7ost.noarch


Actual results:

We have to connect to every console manually to change the boot order.


Expected results:

We should have the ability to tell ironic about the configuration of the boot order by default for all nodes.
Comment 2 Lucas Alvares Gomes 2015-11-10 03:56:47 EST
Ironic already sets the boot mode to PXE (or CDROM in case of virtual media) before starting the deployment (this is done via the management interface). If it's not working then it's a bug.
Comment 3 Lucas Alvares Gomes 2016-05-19 05:54:44 EDT
Hi Nicolas,

Can you elaborate it a bit more? What you mean by "PXE boot configured by default" ? Because Ironic do change the boot device accordingly when deploying a node.

Do you mean something like network boot being disabled in the BIOS/EFI ?!
Comment 5 Angus Thomas 2016-07-13 08:42:21 EDT
I'm closing this, since it hasn't been possible to provide further updates since May. 

If the bug recurs, and can be described in more detail, please re-open this BZ.

Note You need to log in before you can comment on or make changes to this bug.