Bug 1277600 - Race between ifup-ovs and ovs-agent
Race between ifup-ovs and ovs-agent
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity high
: ---
: 7.0 (Kilo)
Assigned To: Jakub Libosvar
Ofer Blaut
: Triaged, ZStream
Depends On:
Blocks: 1176076
  Show dependency treegraph
 
Reported: 2015-11-03 11:00 EST by Jakub Libosvar
Modified: 2016-04-26 17:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 08:52:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 251277 None None None Never

  None (edit)
Description Jakub Libosvar 2015-11-03 11:00:03 EST
Description of problem:
Testing of bug 1275732 revealed I brought only a partial fix to bug 1176076. 

Version-Release number of selected component (if applicable):


How reproducible:
25%

Steps to Reproduce:
1. Define bridge_mappings in ovs-agent
2. 'systemctl restart network' several times
3.

Actual results:
Sometimes ovs-agent calls 'ovs-vsctl list-br' before external bridge is actually created and ovs-agent crashes.

Expected results:


Additional info:
Comment 3 Ofer Blaut 2016-01-20 07:10:52 EST
I have run loop on systemctl restart network and check ovs bridge status as well as L2 agent status , not issue is found 
openstack-neutron-2015.1.2-6.el7ost.noarch
Comment 5 errata-xmlrpc 2016-01-21 08:52:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0060

Note You need to log in before you can comment on or make changes to this bug.