Bug 1277605 - gnome-session quitting is unreliable
gnome-session quitting is unreliable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 11:11 EST by Christian Stadelmann
Modified: 2016-09-28 15:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-28 15:57:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-11-03 11:11:01 EST
Description of problem:
I often cannot logout or shutdown from my gnome session. Some cases:

A) The logout dialog doesn't show up at all. If running from terminal I see this:
$ gnome-session-quit --logout

** (gnome-session-quit:5617): WARNING **: Failed to call logout: GDBus.Error:org.gnome.SessionManager.NotInRunning: Logout interface is only available during the Running phase

B) The logout dialog doesn't show up at all. Logout suddently happens 60 seconds later without me having confirmed that.

C) The logout dialog shows up. But when confirming logout it still doesn't log out.

D) The logout dialog shows up. But when confirming logout it still doesn't log out. It does so 60 seconds later

All of those issues listed above happen with shutdown too. Some might be specific to wayland. A) and C) are present on both Gnome+X and Gnome+Wayland. This issue is not reliably reproducible. I don't know where to start giving you more information, so please give me a hint.

Version-Release number of selected component (if applicable):
gnome-session-3.18.1.2-1.fc23.x86_64
gnome-session-wayland-session-3.18.1.2-1.fc23.x86_64
gnome-session-xsession-3.18.1.2-1.fc23.x86_64
gnome-shell-3.18.1-1.fc23.x86_64
gdm-3.18.0-1.fc23.x86_64
glib2-2.46.1-2.fc23.x86_64

How reproducible:
often (20%…50% of all tries)

Additional info:
This issue is present on the F23 live installation image when shutting down. I don't remember whether it was B) or D).
Comment 1 Christian Stadelmann 2016-06-11 15:29:25 EDT
I haven't seen this on Fedora 24 any more. I'll leave it open since it is a bug with major impact to Fedora 23, which is still officially supported.
Comment 2 Christian Stadelmann 2016-09-28 15:57:50 EDT
Haven't seen this on F24 or F25 any more.

Note You need to log in before you can comment on or make changes to this bug.