Bug 1277606 - pkgdiff is not able to execute abi-compliance-checker correctly
pkgdiff is not able to execute abi-compliance-checker correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pkgdiff (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Richard Shaw
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 11:13 EST by Tomáš Hozza
Modified: 2015-12-30 20:51 EST (History)
1 user (show)

See Also:
Fixed In Version: pkgdiff-1.7.1-1.fc23 pkgdiff-1.7.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:58:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2015-11-03 11:13:00 EST
Description of problem:
pkgdiff is not able to execute abi-compliance-checker correctly and therefore can not generate the ABI difference between packages.

When I run pkgdiff in debug mode I see this in the output:
...
Compare ABIs of geoiplookup (0.03M) ...
Running abi-dumper "/tmp/jy8_c8ppmB/content1/GeoIP-debuginfo-1.5.1-6.fc21.x86_64.rpm/usr/lib/debug/usr/bin/geoiplookup.debug" -lver "1.5.1" -o "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.5.1/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -sort -extra-info "/tmp/jy8_c8ppmB/extra-info"
WARNING: incompatible build option detected: -O2
Running abi-dumper "/tmp/jy8_c8ppmB/content2/GeoIP-debuginfo-1.6.5-1.fc21.x86_64.rpm/usr/lib/debug/usr/bin/geoiplookup.debug" -lver "1.6.5" -o "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.6.5/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -sort -extra-info "/tmp/jy8_c8ppmB/extra-info"
WARNING: incompatible build option detected: -O2
Running abi-compliance-checker -d1 "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.5.1/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -d2 "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.6.5/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -l "geoiplookup" --report-path="pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/details/usr/lib/debug/usr/bin/geoiplookup.debug-diff.html" -quiet
ERROR: Failed to run ABI Compliance Checker (2)
...

When I execute the abi-compliance-checker command by hand I see this:
abi-compliance-checker -d1 "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.5.1/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -d2 "pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/abi_dumps/1.6.5/usr/lib/debug/usr/bin/geoiplookup.debug-ABI.dump.txt" -l "geoiplookup" --report-path="pkgdiff_reports/GeoIP/1.5.1_to_1.6.5/details/usr/lib/debug/usr/bin/geoiplookup.debug-diff.html"
preparation, please wait ...
ERROR: incorrect descriptor (see -d1 option)

It looks like pkgdiff is executing abi-compliance-checker with wrong arguments.

Version-Release number of selected component (if applicable):
pkgdiff-1.7.0-1.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Richard Shaw 2015-11-05 13:57:02 EST
Reported upstream.
Comment 2 Richard Shaw 2015-11-06 14:10:21 EST
Upstream has acknowledged the problem and is planning a fix. Perhaps it's best to downgrade for now?
Comment 3 Fedora Update System 2015-12-14 09:34:42 EST
pkgdiff-1.7.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4cbd240694
Comment 4 Fedora Update System 2015-12-15 05:53:25 EST
pkgdiff-1.7.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pkgdiff'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4cbd240694
Comment 5 Fedora Update System 2015-12-22 10:37:12 EST
pkgdiff-1.7.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-371b21e49a
Comment 6 Fedora Update System 2015-12-28 17:58:05 EST
pkgdiff-1.7.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-12-30 20:51:14 EST
pkgdiff-1.7.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.