Bug 1277634 - content view filter "affected repositories" always shows 0 packages 0 errata
content view filter "affected repositories" always shows 0 packages 0 errata
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Walden Raines
jcallaha
http://projects.theforeman.org/issues...
: Triaged
: 1254158 (view as bug list)
Depends On:
Blocks: 1317008
  Show dependency treegraph
 
Reported: 2015-11-03 12:09 EST by Stuart Auchterlonie
Modified: 2016-07-27 07:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:01:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing 0 packages, 0 errata (127.63 KB, image/png)
2015-11-03 12:10 EST, Stuart Auchterlonie
no flags Details
affected repos (96.15 KB, image/png)
2016-07-01 15:44 EDT, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2121101 None None None 2016-01-12 10:53 EST
Foreman Issue Tracker 14164 None None None 2016-04-26 13:05 EDT

  None (edit)
Description Stuart Auchterlonie 2015-11-03 12:09:13 EST
Description of problem:

When you create a content view filter and switch to the tab to
see the "affected repositories", all the listed repositories
always say 0 packages and 0 errata, making working on filters
near impossible

Version-Release number of selected component (if applicable):

6.1.3

How reproducible:

100%

Steps to Reproduce:
1. Create content view. Add some repositories to content view
2. Create content view filter. does not matter which type
3. Switch to "affected packages" tab.

Actual results:

For all repositories, it lists 0 packages, 0 errata

Expected results:

For all repositories, correctly list the number of packages
and errata the filter affects

Additional info:
Comment 1 Stuart Auchterlonie 2015-11-03 12:10 EST
Created attachment 1089150 [details]
Screenshot showing 0 packages, 0 errata
Comment 5 Walden Raines 2016-03-11 14:00:19 EST
Created redmine issue http://projects.theforeman.org/issues/14164 from this bug
Comment 7 Walden Raines 2016-03-11 14:25:20 EST
PR - https://github.com/Katello/katello/pull/5872
Comment 8 Bryan Kearney 2016-03-11 16:12:44 EST
Upstream bug component is Content Management
Comment 9 Bryan Kearney 2016-03-16 20:12:39 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14164 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|608c7d5db31019675439c97b042dcc541d45d80f.
Comment 10 Brad Buckingham 2016-04-25 12:28:21 EDT
*** Bug 1254158 has been marked as a duplicate of this bug. ***
Comment 11 jcallaha 2016-07-01 15:43:22 EDT
Verified in Satellite 6.2 Beta Snap 18.1.

The affected repositories now display correctly. See attached screenshot.
Comment 12 jcallaha 2016-07-01 15:44 EDT
Created attachment 1175093 [details]
affected repos
Comment 13 Bryan Kearney 2016-07-27 07:01:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.