Bug 127765 - Soundcard Creative Vibra16x PnP not properly configured
Summary: Soundcard Creative Vibra16x PnP not properly configured
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-soundcard   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-13 15:41 UTC by William Kilgore
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 11:06:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/hwconf (3.12 KB, text/plain)
2004-07-21 16:51 UTC, William Kilgore
no flags Details
contents of modules.conf (380 bytes, text/plain)
2004-09-20 18:21 UTC, William Kilgore
no flags Details
modprobe.conf (686 bytes, text/plain)
2005-03-13 13:21 UTC, William Shore
no flags Details

Description William Kilgore 2004-07-13 15:41:56 UTC
Description of problem:
At boot, the card is detected (from dmesg):
  isapnp: Scanning for PnP cards...
  isapnp: SB audio device quirk - increasing port range
  isapnp: Card 'Creative ViBRA16X PnP'
  isapnp: 1 Plug & Play card detected total
/usr/bin/redhat-config-soundcard claims that it can detect no
soundcard.  The hardware browser lists the card as an "unknown device".

Previous installations of RH-7.1 and FC-1 had no problems detecting
and configuring the card.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot machine
2.Fail to hear anything
3.
  
Actual results:
No sound

Expected results:
Sound

Additional info:

Comment 1 Bastien Nocera 2004-07-21 16:41:01 UTC
Please attach your /etc/sysconfig/hwconf to this bug.

Comment 2 William Kilgore 2004-07-21 16:51:50 UTC
Created attachment 102111 [details]
 /etc/sysconfig/hwconf

Comment 3 Bastien Nocera 2004-09-19 13:34:59 UTC
This card should work with the snd-sb16 ALSA driver:
http://www.alsa-project.org/alsa-doc/doc-php/template.php?module=sb16

But it seems that there isn't enough information given by kudzu to
configure it properly. Could you attach your /etc/modprobe.conf file?

Comment 4 William Kilgore 2004-09-20 18:21:13 UTC
Created attachment 104024 [details]
contents of modules.conf

The file /etc/modprobe.conf was requested.  There is no such file.  I assume
this has replaced it.

Comment 5 William Kilgore 2004-12-21 20:00:36 UTC
I responded to the request as best I could, since modprobe.conf seems
to not exist in RHEL.  What is needed if not this?  Why is this bug
still marked "NEEDINFO" three months after I provided the info.  Why
does RedHat not take their support obligations seriously and simply
leave me hanging here month after month with a piece of hardware that
worked with previous RedHat products?

Comment 6 William Shore 2005-03-13 13:21:36 UTC
Created attachment 111939 [details]
modprobe.conf

Comment 7 William Shore 2005-03-13 13:22:28 UTC
I am having the identical problem on FC3. sysconfig/hwconf shows that
the soundcard is found no problem. system-config-soundcard
inexplicably can't find the card. etc/modprobe.conf shows that it is
using the snd-sb16 module.

Please keep me posted of any fixes workarounds to this issue.

Comment 8 Bastien Nocera 2005-04-02 14:24:32 UTC
Which version of RHEL are you using?

Bill, how come this card doesn't show up as Class AUDIO?

Comment 9 Bastien Nocera 2005-04-02 17:07:26 UTC
William Kilgore, if this problem is still current for you, and you have
technical support, I would encourage you to open a call with them. They are the
best able to get time allocated for someone to fix this problem.

William Shore, could you please open a bug against the proper product version
and component? The version of the kernel, and the drivers used are different in
your case.

Comment 10 Bill Nottingham 2005-04-05 17:50:15 UTC
It wouldn't show up in RHEL 4 because the driver isn't built there. In FC3 it
should show up somewhere, I think.

Comment 11 Bastien Nocera 2005-05-09 11:06:09 UTC
Unsupported driver in RHEL4, closing.

Comment 12 William Kilgore 2005-05-09 14:04:40 UTC
Congratulations on a brilliant filibuster!  By pissing away 10 months and then
declaring my hardware obsolete, you have successfully avoided doing a damned
thing.  Yours is truly a creative solution!  Again, I congratulate you!

Comment 13 Bastien Nocera 2005-05-10 08:36:28 UTC
William, if you have a problem with this card not being supported in RHEL, feel
free to bring this up with support, who will pass on your feedback to the
engineers. However, I doubt this card will get much work on given that it is
indeed obsolete, and has been so for a long while.


Note You need to log in before you can comment on or make changes to this bug.