Bug 1277669 - Bad nfs-utils dependency
Bad nfs-utils dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 14:29 EST by Steve Dickson
Modified: 2015-11-03 23:45 EST (History)
1 user (show)

See Also:
Fixed In Version: autofs-5.1.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 23:45:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2015-11-03 14:29:44 EST
Description of problem:
autofs has the following build requires
  BuildRequires: nfs-utils

which is just wrong.

1) nfs-utils is not needed to build autofs 
2) If nfs-utils was needed the BuildRequires 
   should be of nfs-utils-devel not nfs-utils
Comment 1 Ian Kent 2015-11-03 18:45:06 EST
(In reply to Steve Dickson from comment #0)
> Description of problem:
> autofs has the following build requires
>   BuildRequires: nfs-utils
> 
> which is just wrong.

I agree but we've had complains when it wasn't present
and I argued exactly that.

Maybe that was RHEL, can't remember now.

> 
> 1) nfs-utils is not needed to build autofs 
> 2) If nfs-utils was needed the BuildRequires 
>    should be of nfs-utils-devel not nfs-utils

TBH I'm not sure even that is needed.

Let me try a few builds, I'll remove it if it's not
really needed.
Comment 2 Ian Kent 2015-11-03 23:45:52 EST
I've removed the nfs-utils BuildRequires as it doesn't make any
sense.

I haven't added an nfs-utils Requires because autofs can function
without nfs-utils. I'll wait until someone complains before adding
it.

This was actually fixed in the autofs-5.1.1-6 build but I noticed
another problem when inspecting the build log and fixed that in
autofs-5.1.1-7.

Note You need to log in before you can comment on or make changes to this bug.