Bug 1277683 - Split the product-specific plugin (ovirt) from the core (lago)
Split the product-specific plugin (ovirt) from the core (lago)
Status: CLOSED WONTFIX
Product: ovirt-system-tests
Classification: Community
Component: RFEs (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yaniv Bronhaim
Pavel Stehlik
ci
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 15:16 EST by David Caro
Modified: 2016-06-26 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:24:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description David Caro 2015-11-03 15:16:51 EST
Description of problem:
Right now we have the plugin in the same repo than the core, the issue is that the plugin is highly dependent on the ovirt-sdk and ovirt-setup versions, I think it should be moved inside the same repos those reside (maybe split in two if they don't reside in the same repo) and build and distributed alongside it. That will allow to pair the development of both, and have them changed together in the same patches if needed.

If they reside out of the product repos, any change in the product that requires a change in the plugin will create a situation where:
* if you change the tests before merging the patch:
  - you will break all the other patches tests until you merge
  - once merged all the other patches will have to rebase on top of you patch to pass the tests
* if you merge the patch before changing the tests
  - all the patches rebased on it will fail until the tests are changed
  - once the tests are changed, all the patches will fail unless rebased

while moving the plugins code to the same repo allows you to just change the tests in the same patch and contain the changes there, so no other patches break, and no need to rebase before or after you patch is merged

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Caro 2015-11-03 15:18:04 EST
Worth mentioning that just spliting the plugin from the core repo, does not add any advantage, the key is moving it to the same repo as the product it was meant for.
Comment 2 David Caro 2016-01-27 14:24:54 EST
I don't think this is never going to happen...

Note You need to log in before you can comment on or make changes to this bug.