Bug 1277684 - SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /usr/libexec/upowerd.
SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /usr/li...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ed92c2cb99f905b4247bc1d0133...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 15:18 EST by autarch princeps
Modified: 2015-11-08 04:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 04:32:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description autarch princeps 2015-11-03 15:18:35 EST
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /usr/libexec/upowerd.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed open access on the upowerd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:devicekit_power_exec_t:s0
Target Objects                /usr/libexec/upowerd [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           upower-0.99.3-2.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   8
First Seen                    2015-11-03 15:11:26 EST
Last Seen                     2015-11-03 20:13:54 EST
Local ID                      0e72a844-971b-4dd8-b3ab-e690b5fd79fa

Raw Audit Messages
type=AVC msg=audit(1446599634.764:951): avc:  denied  { open } for  pid=6365 comm="abrt-hook-ccpp" path="/usr/libexec/upowerd" dev="dm-0" ino=299086 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:devicekit_power_exec_t:s0 tclass=file permissive=1


Hash: abrt-hook-ccpp,abrt_dump_oops_t,devicekit_power_exec_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-08 04:32:08 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.