Bug 1277706 - virt-sparsify should not sparsify a snapshot
virt-sparsify should not sparsify a snapshot
Status: CLOSED DUPLICATE of bug 1277705
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 16:12 EST by Yaniv Kaul
Modified: 2015-11-04 04:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 04:02:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2015-11-03 16:12:04 EST
Description of problem:
Per my email discussion with Richard:

> 1.When sparsifying, virt-sparsify is only working on the current snap? Is
> that the intention?
virt-sparsify isn't really tested on snapshots at all.  It's expecting
a single base image that it can sparsify.

> 2. Perhaps it should at least warn that there's work to be done on the base?

It could check that, and should probably just stop if it encounters
that.  I can't think of a case where you'd want to sparsify a
snapshot.
Comment 2 Pino Toscano 2015-11-04 04:02:24 EST

*** This bug has been marked as a duplicate of bug 1277705 ***

Note You need to log in before you can comment on or make changes to this bug.