Bug 127772 - sometimes document password protection fails
sometimes document password protection fails
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2004-07-13 12:56 EDT by Dan Stromberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-28 15:01:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dan Stromberg 2004-07-13 12:56:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Openoffice.org writer has a feature for password protecting
wordprocessor documents.

I tried to use a long sentence with lots of spaces as my password for
a document.  OpenOffice writer saved the document without complaint. 
However, upon trying to reread the document, writer consistently said
the password was incorrect.

I thought maybe I had accidentally entered the same incorrect password
twice when creating the document, so I saved a related document with
the same password twice more.  Each time, writer failed to open the
document, saying the password was incorrect.

I then tried saving the same document again using a 9 character,
strictly-alpha password.  This time, writer was able to open the document.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Pick a sentence to use as a long password, with lots of spaces
2. Save an openoffice.org writer document with this password
3. Exit writer and try to reload the document.

Actual Results:  
I get an error saying I have entered the wrong password.

Expected Results:  
writer should have opened the document and allowed me to read the text
and make changes.

Additional info:
Comment 1 Dan Williams 2004-07-13 14:15:41 EDT
fa->cmc: can you take this?
Comment 2 Caolan McNamara 2004-07-26 08:16:05 EDT
hmm, with 1.1.1 I can create a password of
"I have some spac" and I can save it and reload with the same
password, *but* the first couple of times I did it I had the same
problem as you reported because my password was "I have some spaces"
which is 18chars long, on entering the password for save OOo stopped
entering characters after 16letters, while on entering the password
for loading it let me type in as many as I wanted, and my 18letter "I
have some spaces" on load didn't match the saved "I have some spac"
that it was truncated to on the save dialog.

Do you thing this is the same problem that you encountered, i.e. that
the problem is either to allow longer password on save, or truncate on
load to match save
Comment 3 Caolan McNamara 2004-07-26 09:09:00 EDT
http://www.openoffice.org/issues/show_bug.cgi?id=32095 is my proposed
fix for this, i.e. limit the load the same way as save, so an overly
long password behaves the same on load as save
Comment 4 Caolan McNamara 2004-10-28 15:01:32 EDT
This is an upstream issue. Track
http://www.openoffice.org/issues/show_bug.cgi?id=32095 for updates.

Note You need to log in before you can comment on or make changes to this bug.