Bug 1277738 - Error while converting VMware VM - Windows Server 2008 R2 64bit
Error while converting VMware VM - Windows Server 2008 R2 64bit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
V2V
:
Depends On:
Blocks: 1280501
  Show dependency treegraph
 
Reported: 2015-11-03 18:43 EST by Alessandro
Modified: 2015-11-12 09:55 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1190669
: 1277741 (view as bug list)
Environment:
Last Closed: 2015-11-05 03:57:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro 2015-11-03 18:43:03 EST
When running:
virt-v2v -ic vpx://USER@vCenterServer/DC/Cluster/ESXiHost/?no_verify=1 -o libvirt -os virtimages "vmname" --password-file /tmp/password

curl -q --insecure --user '<hidden>' --head --silent --url 'https://vCenterServerName/folder/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29-flat.vmdk?dcPath=DC%20Developer%20Cloud&dsName=virtual%5fccf0444%5ft1%5fsnap07%5f01'
HTTP/1.1 404 Not Found
Date: Tue, 3 Nov 2015 23:32:03 GMT
Set-Cookie: vmware_soap_session="52c848ab-43a0-bef1-07d0-0b42902c1dff"; Path=/; HttpOnly; Secure; 
Connection: close
Content-Type: text; charset=plain
Content-Length: 0

virt-v2v: error: vcenter: URL not found: 
https://vCenterServerName/folder/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29-flat.vmdk?dcPath=DC%20Developer%20Cloud&dsName=virtual%5fccf0444%5ft1%5fsnap07%5f01

DEBUG INFO:

[root@CENTOS7 Scripts]# LIBVIRT_DEBUG=1 virt-v2v -ic vpx://DOMAIN%5cUSERNAME@vCenterServerName/DC%20Developer%20Cloud/Logical%20Folder/Cluster/ESXiHost/?no_verify=1 -o libvirt -os virtimages "conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18)" --password-file /tmp/password
2015-11-03 23:31:59.956+0000: 5748: info : libvirt version: 1.2.17, package: 1.el7 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2015-07-02-03:38:08, x86-024.build.eng.bos.redhat.com)
2015-11-03 23:31:59.956+0000: 5748: debug : virGlobalInit:389 : register drivers
2015-11-03 23:31:59.956+0000: 5748: debug : virRegisterConnectDriver:691 : driver=0x7facd866a620 name=Test
2015-11-03 23:31:59.957+0000: 5748: debug : virRegisterConnectDriver:702 : registering Test as driver 0
2015-11-03 23:31:59.957+0000: 5748: debug : virRegisterConnectDriver:691 : driver=0x7facd866c240 name=ESX
2015-11-03 23:31:59.957+0000: 5748: debug : virRegisterConnectDriver:702 : registering ESX as driver 1
2015-11-03 23:31:59.957+0000: 5748: debug : virRegisterConnectDriver:691 : driver=0x7facd866b0a0 name=remote
2015-11-03 23:31:59.957+0000: 5748: debug : virRegisterConnectDriver:702 : registering remote as driver 2
[   0.0] Opening the source -i libvirt -ic vpx://DOMAIN%5cUSERNAME@vCenterServerName/DC%20Developer%20Cloud/Logical%20Folder/Cluster/ESXiHost/?no_verify=1 conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18)
2015-11-03 23:31:59.993+0000: 5748: debug : virConnectOpenAuth:1339 : name=vpx://DOMAIN%5cUSERNAME@vCenterServerName/DC%20Developer%20Cloud/Logical%20Folder/Cluster/ESXiHost/?no_verify=1, auth=0x7fffd2101a80, flags=0
2015-11-03 23:31:59.993+0000: 5748: info : virObjectNew:202 : OBJECT_NEW: obj=0x16f1e60 classname=virConnect
2015-11-03 23:31:59.993+0000: 5748: info : virObjectNew:202 : OBJECT_NEW: obj=0x16f1fd0 classname=virConnectCloseCallbackData
2015-11-03 23:31:59.993+0000: 5748: debug : virConnectGetConfigFile:953 : Loading config file '/etc/libvirt/libvirt.conf'
2015-11-03 23:32:00.002+0000: 5748: debug : virConfReadFile:769 : filename=/etc/libvirt/libvirt.conf
2015-11-03 23:32:00.009+0000: 5748: debug : virFileClose:102 : Closed fd 4
2015-11-03 23:32:00.009+0000: 5748: debug : do_open:1132 : name "vpx://DOMAIN%5cUSERNAME@vCenterServerName/DC%20Developer%20Cloud/Logical%20Folder/Cluster/ESXiHost/?no_verify=1" to URI components:
  scheme vpx
  server vCenterServerName
  user DOMAIN\USERNAME
  port 0
  path /DC Developer Cloud/Logical Folder/Cluster/ESXiHost/

2015-11-03 23:32:00.009+0000: 5748: debug : do_open:1179 : trying driver 0 (Test) ...
2015-11-03 23:32:00.009+0000: 5748: debug : do_open:1194 : driver 0 Test returned DECLINED
2015-11-03 23:32:00.009+0000: 5748: debug : do_open:1179 : trying driver 1 (ESX) ...
2015-11-03 23:32:00.017+0000: 5748: debug : virAuthGetConfigFilePathURI:52 : Determining auth config file path
2015-11-03 23:32:00.017+0000: 5748: debug : virAuthGetConfigFilePathURI:79 : Checking for readability of '/root/.config/libvirt/auth.conf'
2015-11-03 23:32:00.017+0000: 5748: debug : virAuthGetConfigFilePathURI:88 : Checking for readability of '/etc/libvirt/auth.conf'
2015-11-03 23:32:00.017+0000: 5748: debug : virAuthGetConfigFilePathURI:97 : Using auth file '<null>'
2015-11-03 23:32:00.768+0000: 5748: info : virObjectNew:202 : OBJECT_NEW: obj=0x17de8a0 classname=virCaps
2015-11-03 23:32:00.774+0000: 5748: info : virObjectNew:202 : OBJECT_NEW: obj=0x17aaae0 classname=virDomainXMLOption
2015-11-03 23:32:00.774+0000: 5748: debug : do_open:1194 : driver 1 ESX returned SUCCESS
2015-11-03 23:32:00.774+0000: 5748: debug : virDomainLookupByUUIDString:380 : conn=0x16f1e60, uuidstr=conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18)
2015-11-03 23:32:00.774+0000: 5748: debug : virDomainLookupByName:416 : conn=0x16f1e60, name=conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18)
2015-11-03 23:32:00.814+0000: 5748: info : virObjectNew:202 : OBJECT_NEW: obj=0x1801b70 classname=virDomain
2015-11-03 23:32:00.815+0000: 5748: info : virObjectRef:296 : OBJECT_REF: obj=0x16f1e60
2015-11-03 23:32:00.841+0000: 5748: debug : virDomainGetState:2484 : dom=0x1801b70, (VM: name=conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18), uuid=420eba12-5fac-21a2-42e3-062285ce4d10), state=0x7fffd2101a70, reason=0x7fffd2101a74, flags=0
2015-11-03 23:32:00.860+0000: 5748: debug : virDomainGetXMLDesc:2575 : dom=0x1801b70, (VM: name=conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18), uuid=420eba12-5fac-21a2-42e3-062285ce4d10), flags=1
2015-11-03 23:32:01.376+0000: 5748: debug : virDomainFree:565 : dom=0x1801b70, (VM: name=conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18), uuid=420eba12-5fac-21a2-42e3-062285ce4d10)
2015-11-03 23:32:01.376+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x1801b70
2015-11-03 23:32:01.376+0000: 5748: info : virObjectUnref:261 : OBJECT_DISPOSE: obj=0x1801b70
2015-11-03 23:32:01.376+0000: 5748: debug : virDomainDispose:238 : release domain 0x1801b70 conversion-test-vm2 (f97c63bc-e711-4281-bb57-627c86e06b18) 420eba12-5fac-21a2-42e3-062285ce4d10
2015-11-03 23:32:01.376+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x16f1e60
2015-11-03 23:32:01.376+0000: 5748: debug : virConnectClose:1384 : conn=0x16f1e60
2015-11-03 23:32:01.376+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x16f1e60
2015-11-03 23:32:01.376+0000: 5748: info : virObjectUnref:261 : OBJECT_DISPOSE: obj=0x16f1e60
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x17de8a0
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:261 : OBJECT_DISPOSE: obj=0x17de8a0
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x17aaae0
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:261 : OBJECT_DISPOSE: obj=0x17aaae0
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:259 : OBJECT_UNREF: obj=0x16f1fd0
2015-11-03 23:32:01.384+0000: 5748: info : virObjectUnref:261 : OBJECT_DISPOSE: obj=0x16f1fd0
curl -q --insecure --user '<hidden>' --head --silent --url 'https://vCenterServerName/folder/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29-flat.vmdk?dcPath=DC%20Developer%20Cloud&dsName=virtual%5fccf0444%5ft1%5fsnap07%5f01'
HTTP/1.1 404 Not Found
Date: Tue, 3 Nov 2015 23:32:03 GMT
Set-Cookie: vmware_soap_session="52c848ab-43a0-bef1-07d0-0b42902c1dff"; Path=/; HttpOnly; Secure; 
Connection: close
Content-Type: text; charset=plain
Content-Length: 0

virt-v2v: error: vcenter: URL not found: 
https://vCenterServerName/folder/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29/conversion-test-vm2%20%28f97c63bc-e711-4281-bb57-627c86e06b18%29-flat.vmdk?dcPath=DC%20Developer%20Cloud&dsName=virtual%5fccf0444%5ft1%5fsnap07%5f01

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]
[root@CENTOS7 Scripts]# 


Looks like the tool looks for a "-flat.vmdk" disk that does not exist. The only VMDK present in Datastore is "vDiskName_1.vmdk"

ESXi host and vCenter Server version 5.5.

Is Windows Server 2012 R2 Standard still not supported for the conversion?
Will it be soon as well as Windows 8 and 10?

Libirt version:
libvirt-client-1.2.17-1.el7.x86_64

Virt-v2v version:
virt-v2v-1.28.1-1.48.el7.x86_64

Many Thanks!
Comment 1 Richard W.M. Jones 2015-11-04 11:09:14 EST
> Looks like the tool looks for a "-flat.vmdk" disk that does not exist.
> The only VMDK present in Datastore is "vDiskName_1.vmdk"

That's new to me.  What's the actual directory listing
if you visit that through the vCenter web page?
Comment 2 Alessandro 2015-11-04 12:29:01 EST
(In reply to Richard W.M. Jones from comment #1)
> > Looks like the tool looks for a "-flat.vmdk" disk that does not exist.
> > The only VMDK present in Datastore is "vDiskName_1.vmdk"
> 
> That's new to me.  What's the actual directory listing
> if you visit that through the vCenter web page?

The directory name is same as the vm name. I browse the vm's Datastore using the vSphere Client and not through the Web page. Is that a difference from libvirt/virt-v2v prospective?

The vm's files look fine and there are no snapshots present, which would explain the -flat.vmdk.

The only thing that pops up in my mind as first is that the vm was created using a Template from a vCloud Director environment. I do not know if this can make a difference/create an issue.
Comment 3 Richard W.M. Jones 2015-11-04 12:35:19 EST
It would be helpful if you could go to the vCenter webpage,
navigate down to the VM, and paste here the VM's directory
and all the files in it.  Preferably with the URLs of
everything too.
Comment 4 Alessandro 2015-11-04 13:28:17 EST
(In reply to Richard W.M. Jones from comment #3)
> It would be helpful if you could go to the vCenter webpage,
> navigate down to the VM, and paste here the VM's directory
> and all the files in it.  Preferably with the URLs of
> everything too.

I believe this is what you asked for:

https://vCenterServerName:9443/vsphere-client/#extensionId=vsphere.core.datastore.manage.filesView;context=com.vmware.core.model%3A%3AServerObjectRef~21F3B6D6-26FB-430E-BA4A-BAF302EBA2F8%3ADatastore%3Adatastore-23633~core

This is the URL from the datastore view when clicking on the folder containing the VM's files.
Comment 5 Alessandro 2015-11-04 14:20:33 EST
Richard,
I believe I have found the issue.
The vm I was trying to convert was created using the Fast Provisioning method from vCloud Director.
SO basically the vm VMDK is a snapshot of a source template vm's VMDK.
This is why we see the -flat.vmdk and why Virt-v2v cannot convert the vm.

I am asking for a confirmation about this and confirm this to you asap.

Thanks!
Comment 6 Alessandro 2015-11-04 16:45:04 EST
Richard,
I confirm to you that the VMDK was a snapshot of a source VM.
The vDisk has been consolidated and I have ran the test again, everything works fine now.
You can close this case. 

Thank you!
Comment 7 Richard W.M. Jones 2015-11-05 03:57:28 EST
Closing per comment 6.

Note You need to log in before you can comment on or make changes to this bug.