Bug 127782 - Following update xorg to 6.7.0-5 PC crashes at Gnome and KDE start
Following update xorg to 6.7.0-5 PC crashes at Gnome and KDE start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 16:09 EDT by arie spieker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arie spieker 2004-07-13 16:09:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Following the update from xorg-x11-6.7.0-2 to xorg-x11-6.7.0-5,
(as well as xauth, twm, Mesa-libGL, Mesa-libGLU, devel, libs-data,
tools, libs, base-fonts, 100dpi-fonts, 75dpi-fonts, truetype-fonts,
font-utils, xfs and xdm), PC succesfully started X-windows. However
both during startup of Gnome, as well as KDE (after the sound), the PC
crashed, and responded only to the big button.
The first time this happened, the system tried three times in
succession to restart X-Windows.  The result wa s ablack screen, and
the info that something very bad had happened.

I am using FC2 on a pentium III 450 MHz with nvidia Geforce card and
6101 driver.  kernel version 2.6-435-2.3. Before the update it all
worked fine......

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-5 etc (16 files as indicated by up2date )

How reproducible:
Always

Steps to Reproduce:
1.Restarting the computer was only succesfull at runlevel 3
2. any attempt to get at level 5 (startx) resulted in a hard crash
during the startup of either KDE or GNOME.
3.In the case of KDE the crash happened when KDE arrived at the
videoscreen in the KDE screen. 
    

Actual Results:  see above

Expected Results:  succesfull startup of GNOME or KDE as the case maybe

Additional info:

After rollback to the older versions of the files indicated above, the
problem disappered. By the way, I tool the older versions from the FC2
disks. The new versions (as indicated above) were provided by up2date.
Comment 1 Mike A. Harris 2004-07-13 19:10:35 EDT
We do not support proprietary drivers.  While nothing has changed
in X, and X is unlikely to be the cause of your problem, any time
you upgrade your kernel, you will have this problem as you then no
longer have a proprietary kernel module linked against the new kernel,
so your "nvidia" driver wont work anymore until you reinstall it or
relink it.  That is outside the scope of what Red Hat provides support
for however.  Nvidia has web forums if you require assistance in
getting their driver to work with any particular kernel and/or X
server release.

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 arie spieker 2004-07-14 04:05:45 EDT
I am not sure this bug is a duplicate of 73733. I know from 
experience the behaviour of my PC as a result of "incompatability of 
nvidia drivers with the kernel" : upon the command startx, the system 
crashes promptly.

The reported bug behaviour is however different : X-windows starts as 
expected, both GNOME and KDE start including the graphical display as 
expected. However before the completion of the start of f.e. KDE, the 
PC crashes when KDE has arrived at the screen icon in the KDE screen.

Also, if it would have been an nvidia/kernel related problem, than 
rolling back from the latest till the previous version of Xorg, would 
not have solved the problem (I feel).

Please note, that I am using the latest nvidia driver (6101), which 
according to nvidia is fully compatibel with the FC2 kernel 
(including 4KSTACK etc.)

Are you sure the latest xorg rpms are beyond any doubt ?

Comment 3 Mike A. Harris 2004-07-14 10:04:48 EDT
Bug #73733 is our catch all master duplicate bug report for all
problems that are reported in bugzilla by users using the
unsupported Nvidia proprietary drivers.  The exact nature and
extent of the problem isn't significant per se, as the
"duplicate" is with reference to being unsupported rather than
the specific user technical support problem.  Additionally,
bugzilla is not intended for technical support problems, just
bug tracking, and only for system configurations which we support.

If you require support in resolving this problem, you may find
the Nvidia web forums, or various Red Hat or X related mailing
lists to be helpful.

>Are you sure the latest xorg rpms are beyond any doubt ?

Very, however there is always a chance that anything could
be at fault for a given problem.  Once the problem is reported
to Nvidia, if Nvidia engineers discover that the true nature
of the problem is not driver misinstallation, misconfiguration,
or other incompatibilities, they can report any X.Org problems
that they discover to the X.Org bugzilla at:

    http://bugs.freedesktop.org

Assuming X.Org developers agree that Nvidia (or someone else) has
found a legitimate bug in X.Org, even if it only occurs with the
Nvidia drivers, the issue will be accepted as a legitimate bug and
investigated upstream.

It is very rare that this is the case however.


Comment 4 John Flanagan 2004-09-02 01:39:52 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-417.html

Note You need to log in before you can comment on or make changes to this bug.