Bug 1277867 - yum install docker fails with dependency conflict
yum install docker fails with dependency conflict
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Walsh
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 04:38 EST by Heiko W. Rupp
Modified: 2016-03-31 19:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:22:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2015-11-04 04:38:59 EST
Description of problem:

yum install docker fails

Version-Release number of selected component (if applicable):


[root@pintsize hrupp]# uname -a
Linux pintsize.home.pilhuhn.de 3.10.0-306.0.1.el7.x86_64 #1 SMP Wed Aug 19 16:06:58 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@pintsize hrupp]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 Beta (Maipo)
How reproducible:


Steps to Reproduce:
1. yum install docker - as seen in https://access.redhat.com/articles/881893
2.
3.

Actual results:

--> Abhängigkeitsauflösung beendet
Fehler: Paket: glibc-2.17-78.el7.i686 (rhel-7-server-rpms)
            Benötigt: glibc-common = 2.17-78.el7
            Installiert: glibc-common-2.17-105.el7.x86_64 (@anaconda/7.2)
                glibc-common = 2.17-105.el7
            Verfügbar: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7
            Verfügbar: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.1
            Verfügbar: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.3
            Verfügbar: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.5
            Verfügbar: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-78.el7
Fehler: Paket: policycoreutils-python-2.2.5-15.el7.x86_64 (rhel-7-server-rpms)
            Benötigt: policycoreutils = 2.2.5-15.el7
            Installiert: policycoreutils-2.2.5-19.el7.x86_64 (@anaconda/7.2)
                policycoreutils = 2.2.5-19.el7
            Verfügbar: policycoreutils-2.2.5-11.el7.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-11.el7
            Verfügbar: policycoreutils-2.2.5-11.el7_0.1.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-11.el7_0.1
            Verfügbar: policycoreutils-2.2.5-15.el7.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-15.el7
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Fehler: Paket: glibc-2.17-78.el7.i686 (rhel-7-server-rpms)
            Benötigt: glibc-common = 2.17-78.el7
            Installiert: glibc-common-2.17-105.el7.x86_64 (@anaconda/7.2)
                glibc-common = 2.17-105.el7
            Verfügbar: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7
            Verfügbar: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.1
            Verfügbar: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.3
            Verfügbar: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-55.el7_0.5
            Verfügbar: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-rpms)
                glibc-common = 2.17-78.el7
Fehler: Paket: policycoreutils-python-2.2.5-15.el7.x86_64 (rhel-7-server-rpms)
            Benötigt: policycoreutils = 2.2.5-15.el7
            Installiert: policycoreutils-2.2.5-19.el7.x86_64 (@anaconda/7.2)
                policycoreutils = 2.2.5-19.el7
            Verfügbar: policycoreutils-2.2.5-11.el7.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-11.el7
            Verfügbar: policycoreutils-2.2.5-11.el7_0.1.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-11.el7_0.1
            Verfügbar: policycoreutils-2.2.5-15.el7.x86_64 (rhel-7-server-rpms)
                policycoreutils = 2.2.5-15.el7

Expected results:


Additional info:
Comment 2 Daniel Walsh 2015-11-05 01:01:14 EST
For some reason you have a 32 bit package being sucked in?


glibc-2.17-78.el7.i686 

Any idea why?  Do you have some i686 packages installed?  If you remove them does docker install work?
Comment 3 Heiko W. Rupp 2015-11-05 09:58:26 EST
I did set up 7.2beta from the provided iso as a complete clean install (no upgrade) and then proceeded with the yum install docker, so I did at least not pull it in on purpose.

I don't exactly know how to trace what you are looking for, so I've added some output.

[root@pintsize hrupp]# yum provides glibc
Geladene Plugins: langpacks, product-id, search-disabled-repos, subscription-manager
glibc-2.17-55.el7.i686 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7.x86_64 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.1.i686 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.1.x86_64 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.3.i686 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.3.x86_64 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.5.i686 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-55.el7_0.5.x86_64 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-78.el7.i686 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-78.el7.x86_64 : The GNU libc libraries
Quelle      : rhel-7-server-rpms



glibc-2.17-105.el7.x86_64 : The GNU libc libraries
Quelle      : @anaconda/7.2

# yum repolist
Geladene Plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Repo-ID                                                                       Repo-Name:                                                                             Status
!rhel-7-server-extras-rpms/x86_64                                             Red Hat Enterprise Linux 7 Server - Extras (RPMs)                                        122
!rhel-7-server-optional-rpms/7Server/x86_64                                   Red Hat Enterprise Linux 7 Server - Optional (RPMs)                                    6.151
!rhel-7-server-rpms/7Server/x86_64                                            Red Hat Enterprise Linux 7 Server (RPMs)                                               7.713
repolist: 13.986


This lists the .i686 glibc available on x86_64, but it says the x86_64 version is installed

# yum info glibc
Geladene Plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Installierte Pakete
Name       : glibc
Architektur : x86_64
Version    : 2.17
Ausgabe    : 105.el7
Größe : 13 M
Quelle      : installed
Aus Quelle  : anaconda
Zusammenfassung: The GNU libc libraries
URL        : http://www.gnu.org/software/glibc/
Lizenz      : LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Beschreibung: The glibc package contains standard libraries which are used by
            : multiple programs on the system. In order to save disk space and
            : memory, as well as to make upgrading easier, common system code is
            : kept in one place and shared between programs. This particular package
            : contains the most important sets of shared libraries: the standard C
            : library and the standard math library. Without these two libraries, a
            : Linux system will not function.

Verfügbare Pakete
Name       : glibc
Architektur : i686
Version    : 2.17
Ausgabe    : 78.el7
Größe : 4.2 M
Quelle      : rhel-7-server-rpms/7Server/x86_64
Zusammenfassung: The GNU libc libraries
URL        : http://www.gnu.org/software/glibc/
Lizenz      : LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Beschreibung: The glibc package contains standard libraries which are used by
            : multiple programs on the system. In order to save disk space and
            : memory, as well as to make upgrading easier, common system code is
            : kept in one place and shared between programs. This particular package
            : contains the most important sets of shared libraries: the standard C
            : library and the standard math library. Without these two libraries, a
            : Linux system will not function.



# yum list installed | grep -i glibc
compat-glibc.x86_64                    1:2.12-4.el7                @anaconda/7.2
compat-glibc-headers.x86_64            1:2.12-4.el7                @anaconda/7.2
glibc.x86_64                           2.17-105.el7                @anaconda/7.2
glibc-common.x86_64                    2.17-105.el7                @anaconda/7.2
glibc-devel.x86_64                     2.17-105.el7                @anaconda/7.2
glibc-headers.x86_64                   2.17-105.el7                @anaconda/7.2



# file !$
file /lib64/libc-2.17.so
/lib64/libc-2.17.so: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), BuildID[sha1]=0xa6dfa1b0aaf76a2c3c7e4862b9c40d26f88b4dc2, for GNU/Linux 2.6.32, not stripped
Comment 4 Heiko W. Rupp 2015-11-20 06:46:20 EST
I was out for a few days and just did a yum update to

sh-4.2# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)

and then yum install docker as described - and this time it worked.
So the incompatibility seem to be solved.


Running transaction
  Installieren     : audit-libs-python-2.4.1-5.el7.x86_64                                                                                                              1/8
  Installieren     : libsemanage-python-2.1.10-18.el7.x86_64                                                                                                           2/8
  Installieren     : checkpolicy-2.1.12-6.el7.x86_64                                                                                                                   3/8
  Installieren     : python-IPy-0.75-6.el7.noarch                                                                                                                      4/8
  Installieren     : setools-libs-3.3.7-46.el7.x86_64                                                                                                                  5/8
  Installieren     : policycoreutils-python-2.2.5-20.el7.x86_64                                                                                                        6/8
  Installieren     : docker-selinux-1.8.2-8.el7.x86_64                                                                                                                 7/8
restorecon:  lstat(/var/lib/docker) failed:  No such file or directory
warning: %post(docker-selinux-1.8.2-8.el7.x86_64) scriptlet failed, exit status 255
Non-fatal POSTIN scriptlet failure in rpm package docker-selinux-1.8.2-8.el7.x86_64
  Installieren     : docker-1.8.2-8.el7.x86_64                                                                                                                         8/8
  Überprüfung läuft: setools-libs-3.3.7-46.el7.x86_64                                                                                                                  1/8
  Überprüfung läuft: python-IPy-0.75-6.el7.noarch                                                                                                                      2/8
  Überprüfung läuft: docker-1.8.2-8.el7.x86_64                                                                                                                         3/8
  Überprüfung läuft: checkpolicy-2.1.12-6.el7.x86_64                                                                                                                   4/8
  Überprüfung läuft: docker-selinux-1.8.2-8.el7.x86_64                                                                                                                 5/8
  Überprüfung läuft: libsemanage-python-2.1.10-18.el7.x86_64                                                                                                           6/8
  Überprüfung läuft: policycoreutils-python-2.2.5-20.el7.x86_64                                                                                                        7/8
  Überprüfung läuft: audit-libs-python-2.4.1-5.el7.x86_64                                                                                                              8/8

Installiert:
  docker.x86_64 0:1.8.2-8.el7

Abhängigkeit installiert:
  audit-libs-python.x86_64 0:2.4.1-5.el7          checkpolicy.x86_64 0:2.1.12-6.el7    docker-selinux.x86_64 0:1.8.2-8.el7    libsemanage-python.x86_64 0:2.1.10-18.el7
  policycoreutils-python.x86_64 0:2.2.5-20.el7    python-IPy.noarch 0:0.75-6.el7       setools-libs.x86_64 0:3.3.7-46.el7


# file /lib64/libc-2.17.so
/lib64/libc-2.17.so: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), BuildID[sha1]=508f7ff5f9802fe2fe52fd9f5d19d0d732d55a56, for GNU/Linux 2.6.32, not stripped
Comment 5 Lokesh Mandvekar 2015-11-20 14:15:02 EST
Before we close this, it'd be great if you could also check how things go with the latest build for 1.8.2 https://brewweb.devel.redhat.com/buildinfo?buildID=466768 . This should also handle the restorecon and POSTIN failures that you see in 'yum update' above.
Comment 6 Daniel Walsh 2015-12-01 17:02:45 EST
Should we set it to modified?
Comment 7 Daniel Walsh 2015-12-01 17:02:45 EST
Should we set it to modified?
Comment 11 errata-xmlrpc 2016-03-31 19:22:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0536.html

Note You need to log in before you can comment on or make changes to this bug.