Bug 1277947 - sshuttle fails to run on Fedora23 due to missing requires
sshuttle fails to run on Fedora23 due to missing requires
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sshuttle (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 07:09 EST by Christopher Brown
Modified: 2016-03-24 21:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: sshuttle-0.77.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 10:50:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add python requires statement (355 bytes, patch)
2015-11-04 07:09 EST, Christopher Brown
no flags Details | Diff

  None (edit)
Description Christopher Brown 2015-11-04 07:09:34 EST
Created attachment 1089601 [details]
Patch to add python requires statement

Description of problem:

sshuttle fails to launch due to missing requires of python 2 now that Fedora has moved to python3


Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Install Fedora 23
2. Try to run sshuttle
3. 

Actual results:

/bin/sshuttle: line 4: /usr/bin/python: No such file or directory

Expected results:


Additional info:

Patch for spec file added.

Ultimately it would be great if this was updated to run on python3 but it looks like a dead project. A pity as this is hugely useful software.
Comment 1 Fedora Admin XMLRPC Client 2016-03-04 12:31:38 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2016-03-04 12:32:46 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jonathan Underwood 2016-03-05 10:37:50 EST
Fortunately, there's a new upstream:

https://github.com/sshuttle/sshuttle

We're busy updating the packages on the F24 and rawhide branches to this new upstream at the moment, and once we've got it nicely sorted out there, we'll backport to F23. Watch this space :)
Comment 4 Jonathan Underwood 2016-03-05 11:01:26 EST
Updated packages for F23 can be pulled for testing from here, when the build completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=13239957
Comment 5 Fedora Update System 2016-03-05 11:13:26 EST
sshuttle-0.77-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7de17c1d5c
Comment 6 Fedora Update System 2016-03-05 21:57:02 EST
sshuttle-0.77-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7de17c1d5c
Comment 7 Fedora Update System 2016-03-07 12:02:31 EST
sshuttle-0.77.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7de17c1d5c
Comment 8 Fedora Update System 2016-03-09 17:58:00 EST
sshuttle-0.77.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7de17c1d5c
Comment 9 Christopher Brown 2016-03-16 10:50:03 EDT
Many thanks for the attention on this package.
Looks good from here.
Comment 10 Fedora Update System 2016-03-24 21:27:02 EDT
sshuttle-0.77.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.