Bug 1277952 - Overriding the parameter default value doent adds 1 to the 'Number of Values' count.
Summary: Overriding the parameter default value doent adds 1 to the 'Number of Values'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-11-04 12:16 UTC by Jitendra Yejare
Modified: 2019-09-26 13:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:59:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12393 None None None 2016-04-22 16:24:05 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-11-04 12:16:04 UTC
Description of problem:
Overriding the parameter default value doent adds 1 to the 'Number of Values' count in parameters table in Config -> Smart Class Parameter page.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Override smart class parameter, set the default value.
2. Don't check 'puppet default value' checkbox.
3. See the 'Number Of Values' column for that parameter in Config -> Smart Class Parameters.

Actual results:
The count doesn't adds 1 to the 'Number of Values' for that parameter.

Expected results:
The count for 'Number of Values' should be increased by 1.

Additional info:

Comment 3 Bryan Kearney 2015-11-06 17:04:08 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 4 Bryan Kearney 2016-02-16 15:06:41 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12393 has been closed
-------------
Anonymous
Applied in changeset commit:c49222be9e98155f73d83e21448eb8369c89ff01.

Comment 7 Jitendra Yejare 2016-04-04 09:28:08 UTC
Verified this issue in Sat 6,2 snap 6.1.

I see the 'Number of Values' has been changed to 'Number of Overrides' which makes sense. And also adding a default value doesn't adds 1 to the 'Number of overrides' which is expected.

Moving the bug to verified state.

Comment 9 errata-xmlrpc 2016-07-27 08:59:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.