Bug 1277988 - [vdsbroker] Ignore heartbeat when running setupNetworks
[vdsbroker] Ignore heartbeat when running setupNetworks
Status: CLOSED DUPLICATE of bug 1388778
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Piotr Kliczewski
Pavel Stehlik
:
: 1277991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 08:43 EST by Piotr Kliczewski
Modified: 2016-11-27 07:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-27 07:13:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Piotr Kliczewski 2015-11-04 08:43:11 EST
Description of problem:

Currently when setupNetworks is executed we negotiate heartbeat policy before and after the operation. As a result we drop and create new connection twice.
There are situations that after successful run of the setupNetworks due to connection reset the host is in Connecting state for short period of time.

Version-Release number of selected component (if applicable):


How reproducible:
We need to run setupNetworks serveral time and it is matter of timing that we see this issue.

Steps to Reproduce:
1.
2.
3.

Actual results:
Host changes status to Connecting for short period of time.


Expected results:
Host status should not be changed if setupNetworks operation was successful.

Additional info:
We need to ignore heartbeats on the engine side without negotiations.
Comment 2 Dan Kenigsberg 2016-01-26 03:03:15 EST
*** Bug 1277991 has been marked as a duplicate of this bug. ***
Comment 3 Sandro Bonazzola 2016-05-02 05:58:42 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Yaniv Lavi (Dary) 2016-05-23 09:15:40 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Yaniv Lavi (Dary) 2016-05-23 09:19:29 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Oved Ourfali 2016-05-25 10:15:13 EDT
It would have been nice to have that in 4.1.
However, after it took us a lot of time to get host deploy + setup networks stabilized in 4.0/3.6, I suggest to postpone to 4.1, and do it early in the 4.1 development phase.
Comment 7 Oved Ourfali 2016-11-27 07:13:27 EST
This is the reconnect changes.
Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1388778 ***

Note You need to log in before you can comment on or make changes to this bug.