Bug 1277994 - RFE: extend spacecmd softwarechannel_setorgacces for protected sharing level
RFE: extend spacecmd softwarechannel_setorgacces for protected sharing level
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
Depends On:
Blocks: 1395889 space27
  Show dependency treegraph
 
Reported: 2015-11-04 08:55 EST by bernhard.lichtinger
Modified: 2017-09-27 15:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1395889 (view as bug list)
Environment:
Last Closed: 2017-09-27 15:04:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bernhard.lichtinger 2015-11-04 08:55:27 EST
Description of problem:
Having shared channels between multiple organisations there is no convient way to set the sharing level to protected for a subset of channels with spacecmd.

I extended the spacecmd code and created a pull request:
https://github.com/spacewalkproject/spacewalk/pull/311

Additional info:
Tested it against my spacewalk-2.3 server on CentOS-6 with spacecmd from master.
Also added two commands to set/get orgaccess for a whole channel tree at once.

What do you think about it?
Comment 1 Jan Dobes 2016-03-24 13:25:29 EDT
spacewalk master commit:

95dd6678b33ebf81bb44ad6b6d5533e642f4b8b6
Comment 2 Pavel Studeník 2016-11-29 11:32:09 EST
Verified with spacecmd-2.6.16-1.el6.noarch

help:
..
-p,--protected ORG : protected org access for ORG only (multiple instances of -p ORG are allowed)

>> spacecmd "softwarechannel_setorgaccess example-channel -p ORG-1"
INFO: Connected to https://localhost/rpc/api as admin
INFO: Making org sharing protected for channel : example-channel 
INFO: Enabling ORG-1 access for channel : example-channel
Comment 3 Eric Herget 2017-09-27 15:04:12 EDT
This looks like it was fixed in previous release, but I'm closing it in this one.

Spacewalk 2.7 has been released.

https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes27

Note You need to log in before you can comment on or make changes to this bug.