Bug 1278015 - Problems in bind if you define more then one listening ip and reboot your server
Summary: Problems in bind if you define more then one listening ip and reboot your server
Keywords:
Status: CLOSED DUPLICATE of bug 1294506
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Tomáš Hozza
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-04 14:45 UTC by Ralf Germann
Modified: 2016-11-01 01:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 08:16:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ralf Germann 2015-11-04 14:45:41 UTC
Description of problem: 
On RHEL 7 there seems to be a problem if you define more then one listening ip in /etc/named.conf. If you restart service named, everything looks fine. Listening on all available and configured ip addresses. But if you reboot your server it could be, that named is started, before all configured ip addresses / interfaces are ready to use and because of this named is only listening on some ips or in worst case only on localhost 127.0.0.1.

Temporary workaround which worked for me:
cp /usr/lib/systemd/system/named.service /etc/systemd/system/.
Add Wants=network.target to /etc/systemd/system/named.service
systemctl daemon-reload


Version-Release number of selected component (if applicable): bind-9.9.4-29.el7.x86_64


How reproducible: always, if you have a server with at least 2 interfaces. eth0 looks to the internet and eth1 is the one should listening on port 53.


Steps to Reproduce:
1. yum install bind-* -y
2. vi /etc/named.conf, edit line listen-on port 53 { 127.0.0.1; }; to
listen-on port 53 { 192.168.14.5; 127.0.0.1; }; (or use another ip)
3. systemclt enable named; systemctl start named
4. netstat -anp | grep 53 (everything should be fine)
5. systemctl reboot
6. netstat -anp | grep 53 (only listeing on 127.0.0.1)

Actual results:
Only listening on 127.0.0.1 after reoobt

Expected results:
Should listen also on 192.168.14.5

Additional info:

Comment 2 Tomáš Hozza 2016-05-10 08:16:43 UTC

*** This bug has been marked as a duplicate of bug 1294506 ***


Note You need to log in before you can comment on or make changes to this bug.