Bug 1278024 - Running a RHEL 7.2 guest, with cloud init, and without network interface, ends up with kernel panic on the guest.
Running a RHEL 7.2 guest, with cloud init, and without network interface, end...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Lars Kellogg-Stedman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 10:01 EST by Ilanit Stein
Modified: 2017-01-16 13:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-16 13:31:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
end of trace on guest screenshot (565.27 KB, image/png)
2015-11-04 10:04 EST, Ilanit Stein
no flags Details
1 page before end of trace on guest screenshot (567.17 KB, image/png)
2015-11-04 10:05 EST, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2015-11-04 10:01:20 EST
Description of problem:
while testing rhel guest image (rhel-guest-image-7.2-20151102.0.el7), 
creating a VM from this template, 
configure cloud init user /password.
Run VM, At this stage DO NOT login to into the guest!
power off VM,
add nic,
Run VM -> inside guest kernel panic look alike trace is seen (screen shot attached).
Version-Release number of selected component (if applicable):

Host:
rhel 7.1
vdsm-4.16.28-1.el7ev
libvirt-1.2.8-16.el7_1.4

engine:
vt18, rhevm 3.5.6

How reproducible:
always reproduced, on the same setup

Additional info:
Comment 1 Ilanit Stein 2015-11-04 10:04 EST
Created attachment 1089727 [details]
end of trace on guest screenshot
Comment 2 Ilanit Stein 2015-11-04 10:05 EST
Created attachment 1089728 [details]
1 page before end of trace on guest screenshot
Comment 4 Ilanit Stein 2015-11-04 11:39:25 EST
Bug didn't reproduced by the following flow:
On 
Host:
rhel 7.1
vdsm-4.16.28-1.el7ev
libvirt-1.2.8-16.el7_1.4

engine:
vt18, rhevm 3.5.6

-Install guest on rhevm 3.5.6 vt18, with rhel7.2 latest.
-create a template from it.
-Create a VM from that template
-Remove nic
-edit VM and define cloud init user/password
-Run VM
-power off VM
-add nic
-run VM
Comment 5 Lars Kellogg-Stedman 2017-01-16 13:31:18 EST
I am not able to reproduce this behavior with the current RHEL guest image. If you believe this is still a problem, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.