Bug 127807 - pam-panel-icon opens window on dual-head configuration
pam-panel-icon opens window on dual-head configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 00:15 EDT by Mace Moneta
Modified: 2013-07-02 19:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 11:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2004-07-14 00:15:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040620

Description of problem:
When running a dual-head configuration (laptop with TV-out, and each
displaying a unique X desktop), the pam-panel-icon opens an empty
window (titled "Authentication Indicator").  It also appears in the
tasklist with the same name.  When root authentication is made, the
"Authentication Indicator" window displays the keys icon.

Version-Release number of selected component (if applicable):
usermode-gtk-1.70-2

How reproducible:
Always

Steps to Reproduce:
1.Configure dual-head display
2.Login
3.Observe "Authentication Indicator" in taskbar and small window on
screen.
    

Actual Results:  Window opens, taskbar shows "Authentication
Indicator", keys icon displays in window.

Expected Results:  No window, "Authentication Indicator" hidden from
taskbar, keys icon appears in system tray.

Additional info:

This is very confusing for a user.  The application can't be killed
(it auto-restarts), and identifying the process for bug reporting is
difficult.
Comment 1 Mace Moneta 2004-07-14 00:27:31 EDT
See similar bug 127808 for eggcups.
Comment 2 Mace Moneta 2004-10-20 11:44:08 EDT
This bug is corrected in rawhide (currently FC3T3).  Resolved.
Comment 3 Bart Szyszka 2004-10-25 14:33:25 EDT
I'm currently using Fedora Core 3 Test 3 and this problem has *not*
been corrected. I've always experienced it since the start of the
Fedora project and before. It seems as though the problem appears when
xorg.conf (and whatever that file used to be called...) is edited,
which can be pretty commmon if someone installed X without dual-head
support and wants to enable it later and vice versa.
Comment 4 Mace Moneta 2004-10-25 15:31:55 EDT
I tested this with a clean install of FC3T3 (freshly partitioned and
mke2fs hard drive).  The installation was single head, and I edited
xorg.conf to the configuration I had when the problem was first
reported - I actually copied the backup dual-head configuration back
to /etc/X11.  Dual-head operation no longer causes the problem, for me.

If you installed over an existing installation, it's possible that an
existing configuration file is triggering the problem.  I suggest
adding a new user and logging in to that after restarting X.  If the
problem doesn't occur, then a configuration file in your home
directory is the cause.  If it does occur, then a system file is the
culprit.  Either way it will be difficult and very time consuming to
isolate.  :-(

Note You need to log in before you can comment on or make changes to this bug.