Bug 1278075 - [RFE] OpenStack instance is missing pause, shelve and shelve offload actions
[RFE] OpenStack instance is missing pause, shelve and shelve offload actions
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ronnie Rasouli
openstack
: FutureFeature
Depends On:
Blocks: 1202884 1223825 1291812 1298969
  Show dependency treegraph
 
Reported: 2015-11-04 11:28 EST by Marius Cornea
Modified: 2016-06-29 11:02 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
This CloudForms release adds pause, shelve, and shelve offload to the power operations for OpenStack instances.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:02:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-04 11:28:06 EST
Description of problem:
The OpenStack instances are missing pause, shelve and shelve offload actions.

Version-Release number of selected component (if applicable):
5.5.0.9-beta2.20151102161742_5530c9a

How reproducible:
100%

Steps to Reproduce:
1. Add an Openstack cloud provider
2. Go to cloud instances
3. Click on one of the instances
4. Check the Power menu

Actual results:
Pause, shelve and shelve offload actions are missing.

Expected results:
Pause, shelve and shelve offload actions are present.

Additional info:
Upstream PR:
https://github.com/ManageIQ/manageiq/pull/5177
Comment 2 Greg Blomquist 2015-11-05 10:14:33 EST
Ladas,

I don't know that any of the UI was ever implemented for these actions...Is that right?
Comment 3 Ladislav Smola 2015-11-05 10:17:39 EST
Yeah I did it while ago, though the code was deleted by some rebase. On this level, there are no tests, only counter of features.
Comment 5 Ladislav Smola 2016-01-12 02:45:48 EST
fixed by https://github.com/ManageIQ/manageiq/pull/5177
Comment 6 Ronnie Rasouli 2016-05-30 10:41:12 EDT
existing in 5.6.0.8-rc1-nightly
Comment 8 errata-xmlrpc 2016-06-29 11:02:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.