Bug 127816 - libtool should grok new ld.so.conf syntax
Summary: libtool should grok new ld.so.conf syntax
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-07-14 09:31 UTC by Joe Orton
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-09 18:27:58 UTC


Attachments (Terms of Use)

Description Joe Orton 2004-07-14 09:31:45 UTC
It might be a good idea for libtool to know about the new fc3
/etc/ld.so.conf syntax: libtool is picking up the "include" path now:
                                                                     
                        
# Run-time system search path for libraries
sys_lib_dlsearch_path_spec="/lib /usr/lib include ld.so.conf.d/*.conf
/usr/X11R6/lib /usr/lib/qt-3.3/lib /usr/lib/mysql "
                                                                     
                        
(I haven't noticed any actual problems caused by this)

Comment 1 Daniel Reed 2004-08-17 20:48:28 UTC
Is this a glibc change or a Red-Hat-specific change?

Comment 2 Joe Orton 2004-08-17 20:55:48 UTC
I presume ld.so.conf.d 'include' syntax is in upstream glibc, Roland
can you confirm?

Comment 3 Roland McGrath 2004-08-17 21:06:50 UTC
Indeed it is.

Comment 4 Daniel Reed 2004-08-20 03:49:08 UTC
I have forwarded this to <bug-libtool@gnu.org>; if nobody addresses
this upstream, I'll take a look.

Comment 6 Daniel Reed 2004-10-09 18:27:58 UTC
Migrated to:
http://lists.gnu.org/archive/html/bug-libtool/2004-08/msg00052.html


Note You need to log in before you can comment on or make changes to this bug.