Bug 1278162 - ncorrect ownership set on /dev/vport0p1 on RHEV guests, preventing guest agent from starting
ncorrect ownership set on /dev/vport0p1 on RHEV guests, preventing guest agen...
Status: CLOSED DUPLICATE of bug 1278163
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.5.4
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Vinzenz Feenstra [evilissimo]
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 14:44 EST by Allan Voss
Modified: 2015-11-05 01:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 01:45:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2015-11-04 14:44:51 EST
Incorrect ownership set on /dev/vport0p1 on RHEV guests, preventing guest agent from starting

[root@rhel7system ~]# tail  /var/log/ovirt-guest-agent/ovirt-guest-agent.log
OSError: [Errno 13] Permission denied: '/dev/virtio-ports/com.redhat.rhevm.vdsm'
MainThread::INFO::2015-09-17 10:48:36,098::ovirt-guest-agent::57::root::Starting oVirt guest agent
MainThread::ERROR::2015-09-17 10:48:36,099::ovirt-guest-agent::138::root::Unhandled exception in oVirt guest agent!
Traceback (most recent call last):
  File "/usr/share/ovirt-guest-agent/ovirt-guest-agent.py", line 132, in <module>
    agent.run(daemon, pidfile)
  File "/usr/share/ovirt-guest-agent/ovirt-guest-agent.py", line 63, in run
    self.agent = LinuxVdsAgent(config)
  File "/usr/share/ovirt-guest-agent/GuestAgentLinux2.py", line 371, in __init__
    AgentLogicBase.__init__(self, config)
  File "/usr/share/ovirt-guest-agent/OVirtAgentLogic.py", line 171, in __init__
    self.vio = VirtIoChannel(config.get("virtio", "device"))
  File "/usr/share/ovirt-guest-agent/VirtIoChannel.py", line 150, in __init__
    self._stream = VirtIoStream(vport_name)
  File "/usr/share/ovirt-guest-agent/VirtIoChannel.py", line 131, in __init__
    self._vport = os.open(vport_name, os.O_RDWR)
OSError: [Errno 13] Permission denied: '/dev/virtio-ports/com.redhat.rhevm.vdsm'

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.1 (Maipo)
rhevm-guest-agent-common-1.0.10-2.el7.noarch 

How reproducible:
Intermittent

Steps to Reproduce:
1. Create RHEL 7.1 guest on RHEV
2. Start ovirt-guest-agent on guest

Actual results:
Failure to start with traceback shown above. 

Expected results:
successful agent start

Additional info:
This can be worked around by manually changing the ownership of /dev/vport0p1 to ovirtagent:ovirtagent instead of root:root
Comment 1 Vinzenz Feenstra [evilissimo] 2015-11-05 01:45:05 EST

*** This bug has been marked as a duplicate of bug 1278163 ***

Note You need to log in before you can comment on or make changes to this bug.