Bug 1278185 - [GSS] improve log msg for WELD-000119
[GSS] improve log msg for WELD-000119
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld (Show other bugs)
6.4.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Romain Pelisse
Matej Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 16:25 EST by Shay Matasaro
Modified: 2015-12-09 08:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 08:35:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shay Matasaro 2015-11-04 16:25:22 EST
the current msg is WELD-000119 Not generating any bean definitions from com.jboss.examples.app.ExampleFactory because of underlying class loading error

it would be helpful if the the underlying class name would be included in the log line

also maybe this log message should be at warn?
Comment 5 Romain Pelisse 2015-11-27 08:35:22 EST
The issue has been fixed upstream, in more recent version of Weld, but due to large amount of code refactoring and enhancement, it's not straightforward to backport. 

So I'm closing as WONTFIX, hope it's OK for everybody, if not, please reopen the issue !

Note You need to log in before you can comment on or make changes to this bug.