Bug 1278194 - wget Illegal instruction (core dumped)
wget Illegal instruction (core dumped)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 1278190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 17:04 EST by Hin-Tak Leung
Modified: 2015-11-19 04:53 EST (History)
5 users (show)

See Also:
Fixed In Version: openssl-1.0.2d-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:53:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cat /proc/cpuinfo (4.47 KB, text/plain)
2015-11-05 05:05 EST, Hin-Tak Leung
no flags Details

  None (edit)
Description Hin-Tak Leung 2015-11-04 17:04:51 EST
Description of problem:
A url from itu web site:

$ wget -x -N 'https://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-X.680-201508-I!!PDF-E&type=items'
--2015-11-04 21:48:36--  https://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-X.680-201508-I!!PDF-E&type=items
Resolving www.itu.int (www.itu.int)... 156.106.202.5, 2a00:7580:60:2141::12
Connecting to www.itu.int (www.itu.int)|156.106.202.5|:443... connected.
Illegal instruction (core dumped)



Version-Release number of selected component (if applicable):
wget-1.16.3-2.fc23

How reproducible:
3 times so far.

Steps to Reproduce:
1. as above
2.
3.

Actual results:
core dumped

Expected results:
not core dumped

Additional info:
Comment 1 Hin-Tak Leung 2015-11-04 17:08:04 EST
abrt-cli report does not work,

gdb /usr/bin/wget  /var/spool/abrt/ccpp-2015-11-04-21:48:37-20504/coredump

(gdb) bt
#0  0x00007f5cb97a8c68 in aesni_cbc_sha256_enc () from /lib64/libcrypto.so.10
#1  0x00007f5cb982635e in aesni_cbc_hmac_sha256_cipher () from /lib64/libcrypto.so.10
#2  0x00007f5cb9b863a7 in tls1_enc () from /lib64/libssl.so.10
#3  0x00007f5cb9b78729 in do_ssl3_write () from /lib64/libssl.so.10
#4  0x00007f5cb9b78b45 in ssl3_write_bytes () from /lib64/libssl.so.10
#5  0x0000000000433b3f in openssl_write ()
#6  0x0000000000407e26 in fd_write ()
#7  0x00000000004196f5 in request_send ()
#8  0x000000000041ac4f in gethttp ()
#9  0x000000000041f0c0 in http_loop ()
#10 0x0000000000429634 in retrieve_url ()
#11 0x0000000000406f71 in main ()
(gdb) 

This looks a lot like the other bug I filed on lynx!
Comment 2 Hin-Tak Leung 2015-11-04 17:09:19 EST
# rpm -q openssl
openssl-1.0.2d-2.fc23.x86_64
Comment 3 Tomas Mraz 2015-11-05 03:28:39 EST
*** Bug 1278190 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Mraz 2015-11-05 03:30:41 EST
So this is likely a misdetection of CPU features your machine supports. Can you post the output of cat /proc/cpuinfo ?

What is the machine you use?
Comment 5 Hin-Tak Leung 2015-11-05 05:05 EST
Created attachment 1089996 [details]
cat /proc/cpuinfo

Here is the /proc/cpuinfo. it is an AMD A4-6210 APU for laptop.

BTW, I had another openssl related issue a while ago, worked around with:

OPENSSL_ia32cap=~0x4000000000000000 

where ssh fails after a suspend/resume; apparently something to do with the built-in random number generator. newer openssl stopped using the hardware-based random number generator. maybe related?
Comment 6 Tomas Mraz 2015-11-05 06:53:12 EST
Can you please install debuginfo package for the openssl and when you're at the crash in gdb, can you 'list' the code and also do 'print OPENSSL_ia32cap_P[0]' and 'print OPENSSL_ia32cap_P[1]'?
Comment 7 Hin-Tak Leung 2015-11-05 07:09:55 EST
(gdb) list
24		andl	$1073741824,%eax
25		andl	$268435968,%r10d
26		orl	%eax,%r10d
27		cmpl	$1342177792,%r10d
28		je	aesni_cbc_sha256_enc_avx
29		ud2
30		xorl	%eax,%eax
31		cmpq	$0,%rdi
32		je	.Lprobe
33		ud2
(gdb) 

(gdb) bt
#0  aesni_cbc_sha256_enc () at aesni-sha256-x86_64.s:29
#1  0x00007f6426d0035e in aesni_cbc_hmac_sha256_cipher (ctx=<optimized out>, 
    out=0x1061548 "=\306[\273\372\033sa\335\326\032#\310\303\332tGET /rec/dologin_pub.asp?lang=e&id=T-REC-X.680-201508-I!!PDF-E&type=items HTTP/1.1\r\nCache-Control: no-cache, must-revalidate\r\nPragma: no-cache\r\nUser-Agent: Wget/1.16.3 (linux-gnu)\r\nAcc"..., 
    in=0x1061548 "=\306[\273\372\033sa\335\326\032#\310\303\332tGET /rec/dologin_pub.asp?lang=e&id=T-REC-X.680-201508-I!!PDF-E&type=items HTTP/1.1\r\nCache-Control: no-cache, must-revalidate\r\nPragma: no-cache\r\nUser-Agent: Wget/1.16.3 (linux-gnu)\r\nAcc"..., len=320)
    at e_aes_cbc_hmac_sha256.c:506
#2  0x00007f64270603a7 in tls1_enc (s=0x1056f90, send=1) at t1_enc.c:897
#3  0x00007f6427052729 in do_ssl3_write (s=s@entry=0x1056f90, type=type@entry=23, 
    buf=buf@entry=0x7ffec2603110 "GET /rec/dologin_pub.asp?lang=e&id=T-REC-X.680-201508-I!!PDF-E&type=items HTTP/1.1\r\nCache-Control: no-cache, must-revalidate\r\nPragma: no-cache\r\nUser-Agent: Wget/1.16.3 (linux-gnu)\r\nAccept: */*\r\nAccept"..., len=266, 
    create_empty_fragment=create_empty_fragment@entry=0) at s3_pkt.c:1042
#4  0x00007f6427052b45 in ssl3_write_bytes (s=0x1056f90, type=23, buf_=0x7ffec2603110, len=<optimized out>) at s3_pkt.c:830
#5  0x0000000000433b3f in openssl_write ()
#6  0x0000000000407e26 in fd_write ()
#7  0x00000000004196f5 in request_send ()
#8  0x000000000041ac4f in gethttp ()
#9  0x000000000041f0c0 in http_loop ()
#10 0x0000000000429634 in retrieve_url ()
#11 0x0000000000406f71 in main ()
(gdb) 
(gdb) print OPENSSL_ia32cap_P[0]
$1 = 126615551
(gdb) print OPENSSL_ia32cap_P[1]
$2 = 2128093707
(gdb)
Comment 8 Tomas Mraz 2015-11-05 08:13:30 EST
If you use
export OPENSSL_ia32cap=0x7ED8220B478BFFFF

Does it work?
Comment 9 Hin-Tak Leung 2015-11-05 08:19:05 EST
(In reply to Tomas Mraz from comment #8)
> If you use
> export OPENSSL_ia32cap=0x7ED8220B478BFFFF
> 
> Does it work?

It does. That voodoo needs to somehow go upstream :-).
Comment 10 Tomas Mraz 2015-11-05 08:42:47 EST
It is completely unclear why they test for the Intel CPU bit in addition to the AVX and SSSE3 bits.
Comment 11 Fedora Update System 2015-11-16 12:27:26 EST
openssl-1.0.2d-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-dce26c8310
Comment 12 Fedora Update System 2015-11-18 11:52:51 EST
openssl-1.0.2d-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update openssl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-dce26c8310
Comment 13 Fedora Update System 2015-11-19 04:53:20 EST
openssl-1.0.2d-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.