Bug 1278223 - SELinux is preventing 57656220436F6E74656E74 from 'read' accesses on the file {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi.
SELinux is preventing 57656220436F6E74656E74 from 'read' accesses on the file...
Status: CLOSED DUPLICATE of bug 1185373
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:427f970128ce53e7bb58ee54db0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 20:00 EST by L. J. Casasola
Modified: 2015-11-10 02:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 02:53:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L. J. Casasola 2015-11-04 20:00:44 EST
Description of problem:
SELinux is preventing 57656220436F6E74656E74 from 'read' accesses on the file {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If usted desea usar el paquete plugin
Then debe deshabilitar los controles de SELinux en los complementos de Firefox.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If cree que de manera predeterminada, 57656220436F6E74656E74 debería permitir acceso read sobre  {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep 57656220436F6E74656E74 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi [ file
                              ]
Source                        57656220436F6E74656E74
Source Path                   57656220436F6E74656E74
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   27
First Seen                    2015-11-01 10:27:56 CET
Last Seen                     2015-11-04 18:58:26 CET
Local ID                      427dc216-0bae-4cfa-95c7-e253071fab17

Raw Audit Messages
type=AVC msg=audit(1446659906.610:766): avc:  denied  { read } for  pid=4827 comm=57656220436F6E74656E74 name="{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi" dev="dm-1" ino=2230356 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file permissive=0


Hash: 57656220436F6E74656E74,mozilla_plugin_t,admin_home_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport

Potential duplicate: bug 1185373
Comment 1 Miroslav Grepl 2015-11-10 02:53:04 EST

*** This bug has been marked as a duplicate of bug 1185373 ***

Note You need to log in before you can comment on or make changes to this bug.