Bug 1278226 - Setting LC_ALL no longer required
Setting LC_ALL no longer required
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-theano (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 20:10 EST by Toshio Ernie Kuratomi
Modified: 2016-02-17 22:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 22:32:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2015-11-04 20:10:42 EST
Description of problem:

I was looking into fixing a problem where the python3-theano package was pulling in python2 and saw the following in the python-theano spec file:

  # The python3 build fails with Unicode errors without this
  export LC_ALL=en_US.UTF-8

Thought I should take a look at this as Unicode errors with LC_ALL=C are usually bugs that I can fix and send upstream.  tried a koji scratch build with both of the spec file lines that had that taken out:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11703117

It succeeded on rawhide so it looks like the LC_ALL is no longer required.

Version-Release number of selected component (if applicable):

python-theano-0.7.0-1

rawhide build
Comment 1 Jerry James 2016-02-17 22:32:19 EST
Fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.