Bug 127823 - dvi out from nv driver not working for GeForce FX 5200
dvi out from nv driver not working for GeForce FX 5200
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 07:58 EDT by Benjamin S. Scarlet
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin S. Scarlet 2004-07-14 07:58:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When using the nv driver to drive an MSI card with a GeForce FX 5200
connected via DVI to an LCD screen, starting the X-server produces
only a solid color or garbage, depending on options and extensions used.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0

How reproducible:
Always

Steps to Reproduce:
1. Configure X server for "nv" driver and DVI out (some combination of
Option "CrtcNumber" "1"
and
Option "FlatPanel"
)  
2. Start X-server


Actual Results:  Screen garbage. Usually a solid blue screen, but
depending on whether I try disabling fancy extensions, sometimes
vertial cyan stripes or such. No cursor, no apps. "ps" shows the gdm
greeter happily up and running and this is a fresh install so I don't
think it's an app problem. Switching to the vesa driver makes it work,
but not at acceptable resolution.

Expected Results:  Should have gotten a gdm greeter, or at least a
cursor. No screen garbage.

Additional info:

I realize that since this is the "nv" driver, I'll probably just get
directed to go to the "nv" driver maintainer (who, last I knew, worked
for nvidia). However, with the whole XFree86 -> X.org thing, I'm not
clear on where I should file this bug to get it to the right person.
Comment 1 Mike A. Harris 2004-07-28 13:41:01 EDT
Hi Benjamin,

The canonical bug tracker for X.Org X11 is the "xorg" component
in freedesktop.org bugzilla, located at http://bugs.freedesktop.org

It isn't yet clear who is the official "nv" driver maintainer anymore
upstream, but the best place to file bug reports related to the "nv"
driver is in a central location, which the official X.Org bugzilla
is probably the best currently.

While it is true this is an open source driver in a sense, in
practice, it really isn't very open source, because the driver
source is heavily obfuscated.  It uses hexadecimal I/O addresses
and values rather than symbolic register names and values, thus
making it next to impossible for anyone outside of Nvidia to make
meaningful modifications to the driver.  ;o(

Hopefully Nvidia is still planning on maintaining and updating
the "nv" driver for the future, and will track bugs in the X.Org
bugzilla.

Please paste the URL here if you file a report in freedesktop
bugzilla, and I'll track the issue there also.

Thanks for the report.
Comment 2 Mike A. Harris 2004-09-01 07:47:41 EDT
Status update:  Doing an upstream bug scan/update, and this bug report
does not have an associated upstream bug report to track.

Our Fedora development contains a new release of xorg-x11 which may
resolve this issue, but requires testing by the original reporter.
If the problem still exists in rawhide xorg-x11, whoever is still
experiencing this issue can file a bug report in X.Org bugzilla
as mentioned in comment #1 above, and we will track the issue in
the upstream bugzilla.

Setting status of bug to "MODIFIED" pending testing of rawhide
xorg-x11 by reporter.


Note to QA: Please change bug status to "RAWHIDE" when Fedora Core 3
ships, unless there are additional comments present indicating the
problem still exists.

Note You need to log in before you can comment on or make changes to this bug.