Bug 1278233 - [abrt] dnf: __init__.py:1020:_makeOutput:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)
[abrt] dnf: __init__.py:1020:_makeOutput:UnicodeDecodeError: 'ascii' codec ca...
Status: CLOSED DUPLICATE of bug 1262082
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f7eb69fe21f0324012ceff19c05...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 21:09 EST by Neil
Modified: 2015-11-12 03:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 08:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (873.42 KB, text/plain)
2015-11-04 21:10 EST, Neil
no flags Details
File: backtrace (1.72 KB, text/plain)
2015-11-04 21:10 EST, Neil
no flags Details
File: dso_list (84 bytes, text/plain)
2015-11-04 21:10 EST, Neil
no flags Details
File: environ (2.86 KB, text/plain)
2015-11-04 21:10 EST, Neil
no flags Details

  None (edit)
Description Neil 2015-11-04 21:09:57 EST
Description of problem:
happened after "dnf system-upgrade" without "download --releasever=23 --best"

Version-Release number of selected component:
dnf-1.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python -OO /bin/dnf system-upgrade
dnf-makecache.log: -- No entries --
executable:     /bin/dnf
kernel:         4.2.5-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
__init__.py:1020:_makeOutput:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 117, in _main
    cli.configure(map(ucd, args))
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1033, in configure
    self.command.configure(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 414, in configure
    self.opts = self.parse_args(args)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 398, in parse_args
    dnf.cli.commands.err_mini_usage(self.cli, self.cli.base.basecmd)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 52, in err_mini_usage
    txt = cli.cli_commands["help"]._makeOutput(cmd)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 1020, in _makeOutput
    help_output += "\n\n%s" % summary
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)

Local variables in innermost frame:
help_output: u'system-upgrade [OPCIONES] [download --releasever=VERSION|reboot|clean|log]'
usage: u'[OPCIONES] [download --releasever=VERSION|reboot|clean|log]'
canonical_name: u'system-upgrade'
command: <class 'dnf.plugin.dynamic.system_upgrade.SystemUpgradeCommand'>
summary: 'Preparar el sistema para una nueva versi\xc3\xb3n'
Comment 1 Neil 2015-11-04 21:10:13 EST
Created attachment 1089934 [details]
File: _var_log_dnf.log
Comment 2 Neil 2015-11-04 21:10:15 EST
Created attachment 1089935 [details]
File: backtrace
Comment 3 Neil 2015-11-04 21:10:17 EST
Created attachment 1089936 [details]
File: dso_list
Comment 4 Neil 2015-11-04 21:10:19 EST
Created attachment 1089937 [details]
File: environ
Comment 5 Honza Silhan 2015-11-09 08:11:50 EST
Do `dnf upgrade "dnf-command(system-upgrade)" ---disableplugin=system-upgrade`, please. This should be fixed in dnf-plugin-system-upgrade-0.7

*** This bug has been marked as a duplicate of bug 1262082 ***

Note You need to log in before you can comment on or make changes to this bug.