Bug 1278271 - User Portal reporting all DataCenter are down while creating a new VM from user portal
User Portal reporting all DataCenter are down while creating a new VM from us...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity high
: ovirt-3.6.2
: 3.6.2
Assigned To: jniederm
Petr Matyáš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 01:52 EST by Sarvesh Pandit
Modified: 2016-03-09 16:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a user couldn't create a virtual machine in the User Portal if they only had the InstanceCreator role permissions. It showed "Not available when no Data Center is up." in the New VM dialog even if there was a data center up. Now, the error message has been changed to a more meaningful "There is no Cluster on which you can create a VM. Please check Data Center status and Cluster permissions." Permission checking has been fixed so that InstanceCreator role permissions are sufficient to create a new virtual machine.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 16:14:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2040463 None None None Never
oVirt gerrit 48794 master MERGED userportal: No up DC with cluster with permission message Never
oVirt gerrit 48832 master MERGED core: AddVmCommand allows InstanceCreator role to create VM Never
oVirt gerrit 48980 ovirt-engine-3.6 MERGED userportal: No up DC with cluster with permission message Never
oVirt gerrit 48996 ovirt-engine-3.6 MERGED core: AddVmCommand allows InstanceCreator role to create VM Never

  None (edit)
Description Sarvesh Pandit 2015-11-05 01:52:32 EST
Description of problem:

Even though All Data Centers are up and running and we can create VM's from the Admin Portal but while creating VM from user portal, reporting "Not available when no Data Center is up."

Version-Release number of selected component (if applicable):
rhevm-3.5.4.2-1.3.el6ev.noarch
rhevm-userportal-3.5.4.2-1.3.el6ev.noarch
rhevm-webadmin-portal-3.5.4.2-1.3.el6ev.noarch

How reproducible:
NA

Steps to Reproduce:
NA

Actual results:
"Not available when no Data Center is up." Not able to create VM from User Portal

Expected results:
No error and able to create VM from user portal

Additional info:
Comment 2 Einav Cohen 2015-11-09 09:46:17 EST
please note that in the user portal, Clusters/DCs are displayed based on user's permissions (maybe also quota - not sure). 

so even if the problem reported here is not a bug, but simply a case of missing proper permissions, I would still recommend rephrase the message in the dialog specifically within the user portal to be something like:
"Not available when no Data Center is up, or when permissions/quota is missing or misconfigured".
Comment 3 Petr Matyáš 2016-01-05 05:15:38 EST
Verified on 3.6.2-3
Comment 6 errata-xmlrpc 2016-03-09 16:14:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.