Bug 1278278 - Support GET & POST methods together on REST procedures
Support GET & POST methods together on REST procedures
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling, Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 02:21 EST by Serhat Dirik
Modified: 2016-07-28 06:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 05:29:07 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2712 Major Closed Support GET & POST methods together on REST procedures 2016-07-28 06:57 EDT

  None (edit)
Description Serhat Dirik 2015-11-05 02:21:56 EST
Description of request:
   We can choose only one HTTP Request type  for REST virtual procedures. Is it possible to combine GET & POST as one type ?

Rationale: 

   POST requests are more easy to create for client programmers.On the other hand GET method simplifies testing. Since it's easy to handle both request types on the server side, supporting  both method at the same time may help to improve usability of services.
Comment 1 Matus Makovy 2016-02-05 05:29:07 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.
Comment 2 JBoss JIRA Server 2016-07-12 12:00:55 EDT
stanislav kaleta <skaleta@redhat.com> updated the status of jira TEIIDDES-2712 to Resolved
Comment 3 JBoss JIRA Server 2016-07-28 06:57:28 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2712 to Closed

Note You need to log in before you can comment on or make changes to this bug.