Bug 1278280 - doesn't match the installonly linmit
doesn't match the installonly linmit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 02:25 EST by antonio montagnani
Modified: 2016-05-16 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: yumex-dnf-4.3.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-16 12:22:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2015-11-05 02:25:01 EST
Description of problem:

updated kernel, but when I rebooted I had 4 kernel instead of 3

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install a new kernel
2.
3.

Actual results:
4 choices

Expected results:
3 choices

Additional info:
installonlimit is 3
Comment 1 Tim Lauridsen 2015-11-20 03:43:00 EST
what version of yumex-dnf are you running ?
Comment 2 antonio montagnani 2015-11-20 06:59:19 EST
4.1.4-1.fc23
Comment 3 Tim Lauridsen 2015-11-25 08:33:44 EST
Have you enabled 
"Preferences -> Settings -> Default: Cleanup old instonly packages"

If not then yumex will not remove old kernel version.
Comment 4 antonio montagnani 2015-11-25 12:56:45 EST
(In reply to Tim Lauridsen from comment #3)
> Have you enabled 
> "Preferences -> Settings -> Default: Cleanup old instonly packages"
> 
> If not then yumex will not remove old kernel version.

no, they were not enabled (by default).I suppose that bug is not a bug :-)
Comment 5 Tim Lauridsen 2015-11-27 07:12:20 EST
It would properly be a good idea to have it enabled by default :-)
Comment 6 Tim Lauridsen 2015-11-27 07:19:42 EST
Fixed upstream for 4.1.x & 4.2.x

https://github.com/timlau/yumex-dnf/commit/270a937358f481d0010c10e686b54597a069df0b
Comment 7 Fedora Update System 2016-05-11 05:02:41 EDT
dnfdaemon-0.3.15-1.fc24 yumex-dnf-4.3.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4
Comment 8 Fedora Update System 2016-05-12 05:41:38 EDT
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4
Comment 9 Fedora Update System 2016-05-16 12:22:27 EDT
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.