Bug 1278282 - memory unplug triggers BUG_ON: kernel BUG at mm/memory_hotplug.c:703!
memory unplug triggers BUG_ON: kernel BUG at mm/memory_hotplug.c:703!
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
: ZStream
Depends On: 1275230
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 02:27 EST by Jan Kurik
Modified: 2015-12-07 16:42 EST (History)
14 users (show)

See Also:
Fixed In Version: qemu-kvm-rhev-2.3.0-31.el7_2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275230
Environment:
Last Closed: 2015-12-07 16:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-05 02:27:36 EST
This bug has been copied from bug #1275230 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Yumei Huang 2015-11-11 01:27:27 EST
Reproduce:
kernel: 3.10.0-326.el7.x86_64
qemu:qemu-kvm-rhev-2.3.0-31.el7

Steps:
1. /usr/libexec/qemu-kvm -name rhel72-sn5 -m 4G,slots=8,maxmem=40G -smp 4,sockets=4,cores=1,threads=1 -no-user-config -nodefaults -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -boot menu=on,strict=on -object iothread,id=iothread0 -drive file=/home/guest/rhel72-sn5.img,if=none,id=drive-data-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop  -device virtio-blk-pci,drive=drive-data-disk,id=data-disk,iothread=iothread0,bus=pci.0,addr=0x7 -netdev tap,id=hostnet1,vhost=on -device e1000,netdev=hostnet1,id=net2,mac=10:1a:4a:42:0a:0b,bus=pci.0,addr=0xa -usb -device usb-tablet,id=input0 -vga qxl -spice port=5901,addr=0.0.0.0,disable-ticketing,image-compression=off,seamless-migration=on -monitor unix:/tmp/monitor3,server,nowait -serial unix:/tmp/console,server,nowait

2. Hotplug memory 5 times via script 
#!/bin/bash 
i=0 
while [ $i -lt 5 ] 
do 
echo $i 
sleep 3 
echo "object_add memory-backend-ram,id=mem$i,size=128M"|nc -U /tmp/monitor3 
sleep 2 
echo "device_add pc-dimm,id=dimm$i,memdev=mem$i,slot=$i"|nc -U /tmp/monitor3 
i=$(($i+1)) 
done 

3. Unplug memory 5 times via script; 
#!/bin/bash
i=0
while [ $i -lt 5 ]
do
echo $i
sleep 3
echo "device_del dimm$i"|nc -U /tmp/monitor3
echo "object_del mem$i"|nc -U /tmp/monitor3
sleep 2
i=$(($i+1))
done 

Guest crashed.Got same result "kernel BUG at mm/memory_hotplug.c:703!"

Verify:
kernel: 3.10.0-328.el7.x86_64
qemu: qemu-kvm-rhev-2.3.0-31.el7_2.1

With same steps as above, guest work well, don't crash. 

So the bug is fixed.
Comment 5 Yumei Huang 2015-11-15 23:35:12 EST
Reverify:
kernel: 3.10.0-327.2.1.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7_2.1

With same steps as comment 4, guest works well, don't crash. 
So,the bug is fixed.
Comment 6 Yumei Huang 2015-11-19 03:33:50 EST
Reverify:
kernel: 3.10.0-331.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7_2.2

QE test on above environment with same steps as comment 4, guest works well, don't crash. 
So the bug is fixed.
Comment 7 Yumei Huang 2015-11-23 01:56:57 EST
Reverify:
kernel: 3.10.0-327.3.1.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7_2.3

QE test on above environment with same steps as comment 4, guest works well, don't crash. 
So the bug is fixed.
Comment 12 errata-xmlrpc 2015-12-07 16:42:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2555.html

Note You need to log in before you can comment on or make changes to this bug.