Bug 1278288 - unable to start kdump using systemctl
unable to start kdump using systemctl
Status: CLOSED DUPLICATE of bug 1244057
Product: Fedora
Classification: Fedora
Component: mod_selinux (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KaiGai Kohei
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 02:47 EST by lnie
Modified: 2015-11-06 02:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 02:49:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log1 (2.91 KB, text/plain)
2015-11-05 02:47 EST, lnie
no flags Details
log2 (3.65 KB, text/plain)
2015-11-05 02:47 EST, lnie
no flags Details
the log of selinux (2.14 KB, text/plain)
2015-11-05 22:34 EST, Chao Fan
no flags Details

  None (edit)
Description lnie 2015-11-05 02:47:10 EST
Created attachment 1089977 [details]
log1

Description of problem: 

Version-Release number of selected component (if applicable):
 f23

How reproducible:
always

Steps to Reproduce:
1.systemctl stop kdump
2.systemctl restart kdump
3.

Actual results:


Expected results:
kdump start successfully

Additional info:
Comment 1 lnie 2015-11-05 02:47 EST
Created attachment 1089978 [details]
log2
Comment 2 Chao Fan 2015-11-05 22:34 EST
Created attachment 1090444 [details]
the log of selinux
Comment 3 Chao Fan 2015-11-05 22:57:58 EST
In fedora 22, if I 
#ls -Z /boot/vmlinuz-4.2.3-200.fc22.x86_64
I will get 
system_u:object_r:boot_t:s0

But now in fedora 23, if I
#ls -Z /boot/vmlinuz-4.2.3-300.fc23.x86_64 
I will get
system_u:object_r:modules_object_t:s0

If I do
## /sbin/restorecon -v /boot/vmlinuz-4.2.5-300.fc23.x86_64
the vmlinuz will change from
system_u:object_r:modules_object_t:s0
to
system_u:object_r:boot_t:s0
then, kdump will get the access on vmlinuz and work.

So, I think this bug maybe caused by the change of selinux, I want to know the difference between 
system_u:object_r:modules_object_t:s0 and 
system_u:object_r:boot_t:s0.
And why selinux change it?
Comment 4 Baoquan He 2015-11-06 00:09:33 EST
Hi,

Seems the type of kernel file /boot/vmlinuz-xxx is changed from boot_t to modules_object_t. By executing command "restorecon /boot/vmlinuz-xxx" its type is restored to boot_t, then "systemctl restart kdump" can operate on /boot/vmlinuz-xxx.

Not sure if this is changed on purpose, and is there a way kdump can do to fix it?

Thanks
Baoquan
Comment 5 Baoquan He 2015-11-06 02:49:16 EST

*** This bug has been marked as a duplicate of bug 1244057 ***

Note You need to log in before you can comment on or make changes to this bug.