Bug 12783 - Samba or quota problem - for WinNT 4.0 also (very ambiguous)
Samba or quota problem - for WinNT 4.0 also (very ambiguous)
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Depends On:
  Show dependency treegraph
Reported: 2000-06-21 11:14 EDT by William Keller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-06-21 11:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description William Keller 2000-06-21 11:14:04 EDT

All pardons for the re-post on the message regarding Redhat6.2 and samba 
2.0.7 with quotas enabled on a file system.

It appears that if a quota limit has been reached on a samba share, and a 
new file addition is attempted - the Samba server correctly states 
that "Error, disk is full" - but upon refreshing the folder, the file 
appears to be there in it's enitirety. This is not so - only the portion 
of the file that manages to fit on the remainding space is written - but 
samba reports it back to be of the original size. Logging in under the 
appropriate account name would confirm this - linux reports that the file 
is indeed of it's intended size. But the file is NOT of the intended size, 
rather it's just a name!!! Running a quotacheck -v /whateverthefilesystem  
confirms this.

I've installed Samba 2.0.7 (and even 2.0.6) and the same thing happens. 
Just for my own piece of mind, I downloaded the Solaris Sparc version of 
2.0.7 and it worked like it should. Please note that, I also downloaded 
the source and compiled it myself (even tried disabling --quota-support) 
to no avail. I've only tried this on WinNT4 clients, using SP's ranging 
from 4 to 6a, and all appear to have the same trouble. I've also tested 
Win2K and the same thing happens.

I apologise for this post if a suitable solution is out there.

Distribution used was Redhat 6.2 - ISO image download from mirror site. 
Samba versions tried were 2.07-4 (both - Samba.org and redhat/updates)


William Keller
Comment 1 William Keller 2000-06-27 07:31:44 EDT
Please read


Note You need to log in before you can comment on or make changes to this bug.