Bug 1278300 - filesystem should own /usr/share/licenses directory
filesystem should own /usr/share/licenses directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: filesystem (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Vasik
Robin Hack
: EasyFix
Depends On:
Blocks: 1289025 1305230
  Show dependency treegraph
 
Reported: 2015-11-05 03:28 EST by Petr Pisar
Modified: 2016-11-03 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: filesystem-3.2-21.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:56:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-11-05 03:28:21 EST
Some packages deliver files under /usr/share/licenses:

# ls /usr/share/licenses
cryptsetup-libs-1.6.7              elfutils-0.163      openssh-6.6.1p1
device-mapper-event-libs-1.02.107  gmp-6.0.0           source-to-image-1.0.2
device-mapper-libs-1.02.107        krb5-libs-1.13.2    systemd-219
elfutils-libelf-0.163              lvm2-libs-2.02.130  systemtap-sdt-devel-2.8
elfutils-libs-0.163                lvm2-2.02.130

For example:

# rpm -qf /usr/share/licenses/lvm2-2.02.130/
lvm2-2.02.130-5.el7.x86_64

But the /usr/share/licenses is not provided by any package:

# LC_ALL=en_US.UTF-8 rpm -qf /usr/share/licenses
file /usr/share/licenses is not owned by any package

The /usr/share/licenses should be owned by filesystem package.

Affected package: filesystem-3.2-20.el7.x86_64.
Comment 1 Ondrej Vasik 2015-11-05 15:49:51 EST
Hmmms, /usr/share/licenses is owned by filesystem since Jul 28 2014 (#1121416) - it was too late for RHEL 7.0. But as %license started to work in fedora 19, it make sense to do that change in RHEL 7 as well. Thanks for report.
Comment 9 errata-xmlrpc 2016-11-03 20:56:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2217.html

Note You need to log in before you can comment on or make changes to this bug.