Bug 1278303 - python-tripleoclient missing dependency on passlib
python-tripleoclient missing dependency on passlib
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
Alexander Chuzhoy
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 03:41 EST by Mike Burns
Modified: 2016-04-07 17:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-tripleoclient-0.0.11-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:42:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 250466 None None None Never
Red Hat Product Errata RHEA-2016:0604 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 director Enhancement Advisory 2016-04-07 21:03:56 EDT

  None (edit)
Description Mike Burns 2015-11-05 03:41:32 EST
Description of problem:
a recent change upstream added 

"import passlib.utils as passutils" in utils.py.  This adds a requirement for python-passlib to be installed but this was not added to the spec file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
No module named passlib.utils

Expected results:
cli works

Additional info:
Comment 3 Alexander Chuzhoy 2016-01-07 11:37:52 EST
Verified:
Environment:
python-tripleoclient-0.0.11-5.el7ost.noarch


rpm -q -R python-tripleoclient
instack
instack-undercloud
python(abi) = 2.7
python-ironic-inspector-client
python-ironicclient
python-openstackclient
python-passlib
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
sos
tripleo-common
rpmlib(PayloadIsXz) <= 5.2-1
Comment 5 errata-xmlrpc 2016-04-07 17:42:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.